sysmaster missing
Posted in 2000
Topics: Migration, Import/Export & Data Conversion, Platform-Specific Issues, Versions, Editions & End-of-Life
We're using IDS 7.30.UC-2 on Solaris 2.6/x86 (don't ask). I was
attempting a dbexport, but received an error message indicating that the
database was in use. I ran a mod of Lester Knudsen's "locks" shell
script, and received another error indicating the sysmaster database was
missing. I checked, and it was gone. There was no indication of how it
had disappeared in the message log. The last time the Unix server was
bounced was three days ago, with no trouble. I bounced the instance
again, sysmaster was rebuilt, everything back to norbal.
Anyone else experienced a missing sysmaster? Any leads on the cause?
tia
Red Valsen wrote:
>
> We're using IDS 7.30.UC-2 on Solaris 2.6/x86 (don't ask). I was
> attempting a dbexport, but received an error message indicating that the
> database was in use. I ran a mod of Lester Knudsen's "locks" shell
> script, and received another error indicating the sysmaster database was
> missing. I checked, and it was gone. There was no indication of how it
> had disappeared in the message log. The last time the Unix server was
> bounced was three days ago, with no trouble. I bounced the instance
> again, sysmaster was rebuilt, everything back to norbal.
>
> Anyone else experienced a missing sysmaster? Any leads on the cause?
Sometimes the SYSMASTER DB is not created at initialization
or upgrade time (more likely) or someone may have deleted
it (sysmaster is not needed by the engine just by some of
the tools). You can recreate it by running the
$INFORMIXDIR/lib/buildsmi script as user informix.
--
Art S. Kagel & Family
kagel@erols.com