Re: Backup & Restore
Posted in 1998
Mike Morris wrote:
>
> We have a new informix database based application and we were following
> the vendor's backup and restore procedures (as best we could) and we
> have run into a few problems.
>
> First, what we did:
> onmode -k (offline?)
> ontape -s (archive level 0 backup, no logs)> drop a user table
> ontape -r>
> The results:
> Tape lights flashed and data seemed to go both ways.
> Once the restore completed, we tried to do an onmode -m with no luck.
> We rebooted the Sun server several times to no avail each time the boot
> process which had previously restarted informix and the user's app,
> failed to initialize shared memory.
>
> What have we done wrong ?
> We never even took the tape out of the drive between backup & restore.
> What can we do (short of reloading informix) to fix this ?
>
> TIA
> ---------------------------------------------------
> Mike Morris Sterling Diagnostic Imaging
> Roads go ever ever on... morrisma@sterlingdi.com
> ---------------------------------------------------
Hi,
I tried to backup an IDS that was off-line. The following
message appeared:
Server is in an incompatible state or user authentication failed.
Programm over.
So you cannot have a backup if you shut down your instance before.
Before you do your "drop table ..." I'm sure you will
go back to "OnLine" mode. Otherwise you wouldn't have access
to your databases.
Before you start your "ontape -r" you must go off-line.
It's impossible to perform a complete system backup
in OnLine mode. So possibly you forgot to go off-line
before you started your "ontape -r".
Bye
Stefan Weideneder