RE: Listener -thread error -27001
Posted in 2003
I have a similar error.
listener-thread: err = -25573: oserr = 72: errstr = : Network driver cannot
accept a connection on the port.
System error = 72.
It's on a dual CPU box running AIX. One processor will sit at 100% Usr
utilization while the other sits at 0. Sometimes it will clear itself up
other times the only solution is to hit the power button. *yikes*
I have increased NETTYPE soctcp,2,1000,CPU per IBM's recommendations but no
fix.
IBM says upgrade to 9x
AIX says to upgrade the OS.
Both are cop out excuses and don't explain why the problem happens.
-----Original Message-----
From: Mukanyi Tariro [mailto:Tariro.Mukanyi@icl.co.zw]
Sent: Tuesday, August 05, 2003 11:00 AM
To: 'Michael Mueller'
Cc: informix-list@iiug.org
Subject: RE: Listener -thread error -27001
Thanx I'll try that!
-----Original Message-----
From: Michael Mueller [mailto:michael.mueller01@kay-mueller.de]
Sent: Tuesday, August 05, 2003 4:51 PM
To: Mukanyi Tariro
Cc: informix-list@iiug.org
Subject: Re: Listener -thread error -27001
Try reducing INFORMIXCONTIME to just a few seconds (set on the client
side!). Set it as low as you can. You can use onstat -g ath to see how
long the soctcplst thread will be sleeping. During this time nobody else
will be able to connect:
Threads:
tid tcb rstcb prty status vp-class name
12 1093d4e0 0 3 sleeping secs: 9 1cpu
soctcplst
Maybe you also can find out why it happens so often. What kind of
clients do you have? This is normally caused by a client machine that
crashes (often a PC) before the initial packages between the client and
the server are exchanged or by a hanging network connection.
Michael
Mukanyi Tariro wrote:
> Hi
>
> We are currently using Informix Dynamic Server Version 7.30.UC2 on
UnixWare
> 7.0.1. We keep getting frequent Informix freezes on our server caused by
the
> error numbers 27554, 27001I. In this state connections to the application
> fail:-
>
> listener-thread: err = -27001 :oserr = 0 : errstr =: Read error occurring
> during connection attempt
>
> Our NETTYPE is set as tlitcp,1,300,NET
> We have also tried to reduce the INFORMIXCONTIME to 60 from 300 but there
is
> no change.
>
> Can somebody help us please.
>
> Regards
>
> Tariro Mukanyi
> Support Consultant - ICL Zimbabwe
> * 263-4-252540/55 (Bus)
> * 263-4-703050 (Fax)
>
> sending to informix-list
>
--
=== Michael Mueller ==================
Tel. + 49 8171 63600
Fax. + 49 8171 63615
Web: http://www.mm.kay-mueller.de
http://www.planets.kay-mueller.de
======================================
sending to informix-list
sending to informix-list