Bug - IDS 7.31 FC 6
Posted in 2000
Hello everybody
I think that I've found a bug in IDS 7.31 FC 6 running under HP-UX
version B.11.00.A
One of the developers was performing an SQL query to modify the
structure of a table, adding a column to it which could not accept
nulls. This query was running within a transaction. Due to the table
had rows in it, the command received an error, and the developer rolled
back the transaction. After that, the database became inaccessible,
with the following errors found in the Informix message log:
---------------------------------------------------------
10:12:49 Checkpoint Completed: duration was 0 seconds.
10:15:45 Assert Failed: Page Check Error in bfput
10:15:45 Informix Dynamic Server Version 7.31.FC6
10:15:45 Who: Session(114, grace@ulysses, 21033, 57232544)
Thread(137, sqlexec, c00000000365e8d8, 1)
File: rsdebug.c Line: 1035
10:15:45 Results: Possible inconsistencies in'sahd:"informix".sysdistrib'
10:15:45 Action: Run 'oncheck -cDI sahd:"informix".sysdistrib'
10:15:45 stack trace for pid 1595 written to /tmp/af.4710bc0Assertion Failure Type: FAILURE
Host Name: ulysses
Database Server Name: infordeulyssessm
Time of failure: Mon Dec 11 10:15:47 MST 2000
AF file: /tmp/af.4710bc0
Shared memory file: None
System Blocking: OFF
10:15:54 See Also: /tmp/af.4710bc0
10:15:54 Assert Failed: Rollback error 172
10:15:54 Informix Dynamic Server Version 7.31.FC6
10:15:54 Who: Session(114, grace@ulysses, 21033, 57232544)
Thread(137, sqlexec, c00000000365e8d8, 1)
File: rsextlog.c Line: 1448
10:15:54 Results: Log record (OLDRSAM:DELITEM) in log 945, offset0x5e320c was not rolled back
10:15:54 Action: Use 'onlog' to view the transaction and repair
manually.
10:15:54 stack trace for pid 1595 written to /tmp/af.4710bc0
10:15:54 Process exited with return code 126: /bin/sh /bin/sh -c
/tmp/infordesv.log 4 1 "Table failure: 'sahd:"informix".sysdistrib'.""Page Check Error in bfput" /tmp
10:15:54 Process exited with return code 126: /bin/sh /bin/sh -c/tmp/infordesv.log 4 6 "Internal Subsystem failure: 'General'" "Page
Check Error in bfput" /tmp/af.471
Assertion Failure Type: FAILURE
Host Name: ulysses
Database Server Name: infordeulyssessm
Time of failure: Mon Dec 11 10:15:54 MST 2000
AF file: /tmp/af.4710bc0
Shared memory file: None
System Blocking: OFF
10:16:01 See Also: /tmp/af.4710bc0
10:16:01 Process exited with return code 126: /bin/sh /bin/sh -c/tmp/infordesv.log 3 10 "Logical Recovery failed." "Rollback error 172"
/tmp/af.4710bc0
10:18:07 Checkpoint Completed: duration was 0 seconds.
10:23:10 Checkpoint Completed: duration was 0 seconds.
10:28:13 Checkpoint Completed: duration was 0 seconds.
---------------------------------------------------
To solve this, we had to perform the oncheck command as written on the
message log:
'oncheck -cDI sahd:"informix".sysdistrib'
The oncheck program detected an error and prompted us to fix it. After
that, the database was OK again. We performed many oncheck commands to
certify that everything was really OK.
This error occurs only with errors on SQL commands wich affect table
structures. Nothing happens if you have an error in a data manipulation
query within a transaction. We repeated these steps and the result was
the same.
In my opinion, this seems to be a bug, because I've never seen this on
other versions of IDS or on other platforms (IBM, Sun, etc).
Is there any way to confirm this ??? If so, is there any solution to
this problem ??
Thanks for any help.
--
Paulo Roberto Marelli de Amorim
TS&0 Consulting
Brasil
Sent via Deja.com http://www.deja.com/
Before you buy.