Unable to grant select on view to user (error:302)
Posted in 2013
Topics: Security, Permissions & Auditing
Hi Technical Support Team,
I am using IDS 11.70 FC7 on AIX.
I am having a very strange situtation. I have an instance which is having
views which are using the synonyms (pointing to another database).
Now, I want to grant the select permissions on a view using it owner but it is
giving me the following error:
SQL Statement:
grant select on owner.view-name to user-name as owner;Error:
302: No GRANT option or illegal option on multi-table view
The problem is that I am able to grant select on a other view (which is also
using the synonyms) without any problem.
Urgent help is needed to resolve the situation, as it is impacting our
production business.
Thanks.
Regards,
Khan
Have you tried connecting to the server as the view owner and granting the
privilege without the AS "owner_name" clause? How about dropping the view
and recreating it as user informix then you should have no problem granting
privileges on it logged in as informix.
Art
Art S. Kagel, Principal Consultant
Advanced DataTools (www.advancedatatools.com)
Blog: http://informix-myview.blogspot.com/
Disclaimer: Please keep in mind that my own opinions are my own opinions
and do not reflect on my employer, Advanced DataTools, the IIUG, nor any
other organization with which I am associated either explicitly,
implicitly, or by inference. Neither do those opinions reflect those of
other individuals affiliated with any entity with which I am affiliated nor
those of the entities themselves.
On Mon, Nov 18, 2013 at 1:26 PM, O KHAN <theultimateboy@hotmail.com> wrote:
> Hi Technical Support Team,
>
> I am using IDS 11.70 FC7 on AIX.
>
> I am having a very strange situtation. I have an instance which is having
> views which are using the synonyms (pointing to another database).
>
> Now, I want to grant the select permissions on a view using it owner but
> it is
> giving me the following error:
>
> SQL Statement:
> grant select on owner.view-name to user-name as owner;> Error:
> 302: No GRANT option or illegal option on multi-table view>
> The problem is that I am able to grant select on a other view (which is
> also
> using the synonyms) without any problem.
>
> Urgent help is needed to resolve the situation, as it is impacting our
> production business.
>
> Thanks.
>
> Regards,
> Khan
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--089e01176b290e892804eb77c759
Art,
Thanks for your response. Yeh, I have tried the option of logged in a owner
and tried executing the grant "without as owner", but i still get the same
error:
302: No GRANT option or illegal option on multi-table view.
Also, please note that I cannot create that view as informix, as i have to
keep it in the seperate schema/ownership than informix.
I have some views which are working in exactly the same situation but some are
not working.
Do you know of any known problem/limitations related to such grants if we are
using the views which are built of synonyms pointing to any other database
instance?
I look forward for your further support. Thanks.
Regards,
Khan