Problem in Informix on Linux.
Posted in 2000
Topics: Installation, Setup & Upgrades, Server Administration, Platform-Specific Issues
Hi,
I install the Informix IDS on Linux and it is ok.
But, a have the following problems:
My environment variables:
INFORMIXDIR=/opt/informix
INFORMIXSERVER=demo_on
The oninit command execute this error.
[informix@cminfo informix]$ oninit -i
This action will initialize Informix Dynamic Server;
any existing Informix Dynamic Server databases will NOT be accessible -
Do you wish to continue (y/n)? y
20:16:45 shmget: [38]: key 52564801: operating system error
20:16:45 mt_shm_init: can't create resident segment
oninit: Fatal error in shared memory creation
When I try to connect in demo_on DATABASE with dbaccess the following error
occurs.
25588: The appl process cannot connect to Dynamic server demo_on.No such file or directory
Have anybody the solution of this problem ?
Thank's.
Marcos Alves
email: marcosaoalves@ig.com.br
"CM Informática" wrote:
> I install the Informix IDS on Linux and it is ok.
The install worked OK, but the configuration is giving you problems?
Which IDS? 7.30.UC7 or IDS.2000 (9.20.Uxy)?
> But, a have the following problems: My environment variables:
>
> INFORMIXDIR=/opt/informix
> INFORMIXSERVER=demo_on
That is a very minimal set of variables; you'll need to set ONCONFIG too,
and should set PATH and ...
> The oninit command execute this error.
>
> [informix@cminfo informix]$ oninit -i
> This action will initialize Informix Dynamic Server;
> any existing Informix Dynamic Server databases will NOT be accessible -
> Do you wish to continue (y/n)? y
>
> 20:16:45 shmget: [38]: key 52564801: operating system error
> 20:16:45 mt_shm_init: can't create resident segment>
> oninit: Fatal error in shared memory creation
So OnLine didn't start -- you can't use it.
Either your kernel has configuration problems (what are you using?),
or you should try setting the shared memory non-resident. Have you
set up sqlhosts correctly? /etc/services? $ONCONFIG?
And you do realize that you only ever use 'oninit -i' the first time
you bring up a database system; thereafter, you use just 'oninit' unless
you want to destroy your databases.
Finally, I usually use onmonitor to bring up a system for the first time;
it allows me to (and forces me to) check the settings in $ONCONFIG.
--
Jonathan Leffler (jleffler@informix.com, jleffler@earthlink.net)
Guardian of DBD::Informix v0.95 -- see http://www.perl.com/CPAN
#include <disclaimer.h>