RE: max number of connections
Posted in 2003
Topics: Versions, Editions & End-of-Life
This is very abnormal and suggests a fault with OS or Informix setup / configuration. Open a case with Tech Support. Anything in the messages log? Do onstats give you information on what the engine is doind or waiting for? MW > -----Original Message----- > From: owner-informix-list@iiug.org > [mailto:owner-informix-list@iiug.org]On Behalf Of Micha > Sent: Monday, 10 November 2003 9:40 a.m. > To: informix-list@iiug.org > Subject: Re: max number of connections > > > I've made a test now - I've started 10 new processes and each > has opened a > connection to the database. The effect was immediate - all > CONNECT's have > succeeded without any error and the database froze until I've > killed them. > Is this supposed to be the documented behaviour? Why are > those CONNECTs not > refused with an SQL error message? This is IDS 7.31 on sunos_i386. > > --Micha > sending to informix-list
"Murray Wood (IList)" wrote:
> This is very abnormal and suggests a fault with OS or Informix setup /
> configuration.
> Open a case with Tech Support. Anything in the messages log? Do onstats
> give you information on what the engine is doind or waiting for?
The logs show nothing. The problem is that it happens say once per day and
one cannot wait at the terminal the whole day long to type an onstat query.
We have a watchdog program that finds the hangup and sends an error message
but till we get it, it is already over. And I don't think we have a support
contract, so tech support is not an option :-(
--Micha