HPL hanging on 9.30 FC3 (aix 5.2)
Posted in 2004
Topics: General Discussion
Hello All When using HP , loading a big table 198 mil records, HPL hangs after the second file. It is a strait load from file, no conversions. There are no errors in the log file, the server CPU and memory is fine. No errors in the online log as well. The server has 4 CPU's and 8 GB memory. PLOAD_SHMAT is set to 1 Here is the plconfig.std # System Configuration CONVERTTHREADS 1 # Number of conversion threads per device CONVERTVPS 3 # Max number of vps for converters (total) # Buffer Configuration STRMBUFFSIZE 128 # Buffer size for server stream buffer (kbytes) STRMBUFFERS 5 # Number of server stream buffers per device AIOBUFSIZE 64 # Buffer size for tape/file I/O (kbytes) AIOBUFFERS 5 # Number of buffers for I/O per device Any suggestions where I can start looking for the problem? Regards, Alinda Watson =93This e-mail is sent on the Terms and Conditions that can be accessed b= y Clicking on this link http://www.vodacom.net/legal/email.asp "
I'm going to assume here that you're running on a p-series server and that
you have the same problem we experienced. We were the first to hit this
problem back in June 2002 when we received one of the very early p-690's.
The problem was exclusive to this platform at the time. Later that year
other p-690 customers had experienced the same problem.
We initially encountered the problem in 9.21uc5-2 and also confirmed it
later in 9.30fc2 on AIX 5.1 in both 32-bit and 64-bit mode. For these
versions of Informix, it required a patched onpload binary. I know they
were implementing a permanent code fix for later releases, but I can't tell
where it was finalized. I also don't recall the actual bug id. I can give
you my case number as a reference when dealing with tech support. Our case
# was 311006. Hope this helps.
Barry Leb
Senior DBA - Informix/DB2
John H. Harland
bjleb@harland.net
770.593.5050 x6137
"Alinda Watson"
<alinda.watson@vcontrac To: ids@iiug.org
tor.co.za> cc:
Sent by: Subject: HPL hanging on 9.30 FC3 (aix 5.2) [2637]
forum.subscriber@iiug.o
rg
03/09/2004 10:24 AM
Hello All
When using HP , loading a big table 198 mil records, HPL hangs after the
second file. It is a strait load from file, no conversions.
There are no errors in the log file, the server CPU and memory is fine.
No errors in the online log as well.
The server has 4 CPU's and 8 GB memory.
PLOAD_SHMAT is set to 1
Here is the plconfig.std
# System Configuration
CONVERTTHREADS 1 # Number of conversion threads per
device
CONVERTVPS 3 # Max number of vps for converters
(total)
# Buffer Configuration
STRMBUFFSIZE 128 # Buffer size for server stream buffer
(kbytes)
STRMBUFFERS 5 # Number of server stream buffers per
device
AIOBUFSIZE 64 # Buffer size for tape/file I/O (kbytes)
AIOBUFFERS 5 # Number of buffers for I/O per device
Any suggestions where I can start looking for the problem?
Regards,
Alinda Watson
=93This e-mail is sent on the Terms and Conditions that can be accessed b=
y Clicking on this link http://www.vodacom.net/legal/email.asp "
The information contained in this electronic mail transmission is the
property of the John H Harland Company. It is intended only for the use of
the individual or entity named above and is privileged and confidential.
Any other use, dissemination, distribution or copying of this communication
is strictly prohibited. If you have received this communication in error
please notify the sender immediately, delete it from your system and
destroy any printouts and/or copies.
This message and any attachments have
been scanned by Symantec Anti-Virus prior to leaving the originator's
network.
Log a case with Tech Support? -- Bye now, Obnoxio "C'est pas parce qu'on n'a rien à dire qu'il faut fermer sa gueule" - Coluche "Necrophilia means never having to say ... well, anything!" - Captain Pedantic "Ogni uomo mi guarda come se fossi una testa di cazzo" - Marco From: "Alinda Watson" <alinda.watson@vcontractor.co.za> > >When using HP , loading a big table 198 mil records, HPL hangs after the >second file. It is a strait load from file, no conversions. >There are no errors in the log file, the server CPU and memory is fine. >No errors in the online log as well. > >The server has 4 CPU's and 8 GB memory. >PLOAD_SHMAT is set to 1 > >Here is the plconfig.std > ># System Configuration > >CONVERTTHREADS 1 # Number of conversion threads per >device >CONVERTVPS 3 # Max number of vps for converters >(total) > ># Buffer Configuration > >STRMBUFFSIZE 128 # Buffer size for server stream buffer >(kbytes) >STRMBUFFERS 5 # Number of server stream buffers per >device >AIOBUFSIZE 64 # Buffer size for tape/file I/O (kbytes) >AIOBUFFERS 5 # Number of buffers for I/O per device > > >Any suggestions where I can start looking for the problem? _________________________________________________________________ Tired of 56k? Get a FREE BT Broadband connection http://www.msn.co.uk/specials/btbroadband