Compression Shrink Option
Posted in 2011
Topics: General Discussion
Good Morning, IDS 11.50.FC5 AIX 5.3 I am just beginning to take advantage of the compression feature. All went well testing but when I went to a prod server I ran into a problem with the shrink option. As soon as it started it failed with the following message in the online.log: 20:39:06 rscCommand: This operation cannot run concurrently with an archive.isfd = 12, table = 'fin2:"informix".maintenance_log', iserrno 147 20:39:06 ERROR fin2:"informix".maintenance_log: rscCommand failed for partnum 2097386 20:39:06 Shrink operation failed for fin2:"informix".maintenance_log, iserrno 0 20:39:06 ERROR: admin_fragment_command('fragment compress repack shrink ','2097386') failed From the error, I obviously cannot run the shrink option while an archive is active but my question is what happens when I restart the shrink? Does it somehow take off where it failed or restart from the beginning? When I tested this in dev, it took about 3 days to compress, repack, & shrink a fragment in this partition. If this behavior repeats itself in prod, i am looking at not being able to run an archive for 3 days??? Obviously I have something to take back to the dev box and test but I would like any insight that anyone may already have on this. Thanx, Dan
Hi Dan, In my testing of these .. The compression takes the most time ... followed by the repack .. and finally the shrink. When I tested them individually the shrink took only a few seconds ... From what I understand that no matter where the process fails, it picks up from that point and continues when you restart the process ... Ie. the repack portion is taking from the back of a table, and loading that into holes at the front of the table ... The compression will indicate in the header when the table is compressed .. So, I think you should be ok if you have to stop the process to then do the archive ... Hope this helps ... and if I messed anything up, I'm sure that Art or John can correct my errors.... Peter Peter Logan Senior Database Administrator Phone: 616/878-8309 From: "DAN MUELLER" <dan.mueller@trnswrks.com> To: ids@iiug.org Date: 01/13/2011 08:36 AM Subject: Compression Shrink Option [22401] Sent by: ids-bounces@iiug.org Good Morning, IDS 11.50.FC5 AIX 5.3 I am just beginning to take advantage of the compression feature. All went well testing but when I went to a prod server I ran into a problem with the shrink option. As soon as it started it failed with the following message in the online.log: 20:39:06 rscCommand: This operation cannot run concurrently with an archive.isfd = 12, table = 'fin2:"informix".maintenance_log', iserrno 147 20:39:06 ERROR fin2:"informix".maintenance_log: rscCommand failed for partnum 2097386 20:39:06 Shrink operation failed for fin2:"informix".maintenance_log, iserrno 0 20:39:06 ERROR: admin_fragment_command('fragment compress repack shrink ','2097386') failed >From the error, I obviously cannot run the shrink option while an archive is active but my question is what happens when I restart the shrink? Does it somehow take off where it failed or restart from the beginning? When I tested this in dev, it took about 3 days to compress, repack, & shrink a fragment in this partition. If this behavior repeats itself in prod, i am looking at not being able to run an archive for 3 days??? Obviously I have something to take back to the dev box and test but I would like any insight that anyone may already have on this. Thanx, Dan ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum.
It is supposed to be an incremental operation, so it SHOULD pick up where it left off. You should be able to examine the compression status of the table and see that it is partially compressed now. Art Art S. Kagel Advanced DataTools (www.advancedatatools.com) IIUG Board of Directors (art@iiug.org) Blog: http://informix-myview.blogspot.com/ Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on my employer, Advanced DataTools, the IIUG, nor any other organization with which I am associated either explicitly, implicitly, or by inference. Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves. On Thu, Jan 13, 2011 at 8:36 AM, DAN MUELLER <dan.mueller@trnswrks.com>wrote: > Good Morning, > > IDS 11.50.FC5 > AIX 5.3 > > I am just beginning to take advantage of the compression feature. All went > well testing but when I went to a prod server I ran into a problem with the > shrink option. As soon as it started it failed with the following message > in > the online.log: > > 20:39:06 rscCommand: This operation cannot run concurrently with an > archive.isfd = 12, table = 'fin2:"informix".maintenance_log', iserrno 147 > 20:39:06 ERROR fin2:"informix".maintenance_log: rscCommand failed for > partnum > 2097386 > 20:39:06 Shrink operation failed for fin2:"informix".maintenance_log, > iserrno > 0 > 20:39:06 ERROR: admin_fragment_command('fragment compress repack shrink > ','2097386') failed > > >From the error, I obviously cannot run the shrink option while an archive > is > active but my question is what happens when I restart the shrink? Does it > somehow take off where it failed or restart from the beginning? When I > tested > this in dev, it took about 3 days to compress, repack, & shrink a fragment > in > this partition. If this behavior repeats itself in prod, i am looking at > not > being able to run an archive for 3 days??? > > Obviously I have something to take back to the dev box and test but I would > like any insight that anyone may already have on this. > > Thanx, > Dan > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --001636c5c1eba9606a0499bb86e8
The work compress, repack does is not lost when interrupted. Let's take the example of compressing a 1 million row table. If the operation had compressed 800,000 rows and then the operation was interrupted. You will NOT have to redo the 800,000 rows when you restart the compression operation, but rather only compress the remaining 200,000 rows. Any new rows added to table before you restart will already be compressed when the are inserted. As for repack, this operation always starts at the end of the table and moves data to the beginning. It does this by using a low level delete, positioning at the first free slot, then re-insert of the data. When the first free slot is the same slot the data was delete from the operation is complete. So there is no wasted effort if this operation is interrupted it will pickup right where it left off. Now the shrink operation is not restartable, it is an all or nothing operation. This operation generally is very short in duration (generally a couple seconds). Hope this helps. John F. Miller III STSM, Embedability Architect miller3@us.ibm.com 503-578-5645 IBM Informix Dynamic Server (IDS) ids-bounces@iiug.org wrote on 01/13/2011 06:56:50 AM: > [image removed] > > Re: Compression Shrink Option [22403] > > Art Kagel > > to: > > ids > > 01/13/2011 06:59 AM > > Sent by: > > ids-bounces@iiug.org > > Please respond to ids > > It is supposed to be an incremental operation, so it SHOULD pick up where it > left off. You should be able to examine the compression status of the table > and see that it is partially compressed now. > > Art > > Art S. Kagel > Advanced DataTools (www.advancedatatools.com) > IIUG Board of Directors (art@iiug.org) > Blog: http://informix-myview.blogspot.com/ > > Disclaimer: Please keep in mind that my own opinions are my own opinions and > do not reflect on my employer, Advanced DataTools, the IIUG, nor any other > organization with which I am associated either explicitly, implicitly, or by > inference. Neither do those opinions reflect those of other individuals > affiliated with any entity with which I am affiliated nor those of the > entities themselves. > > On Thu, Jan 13, 2011 at 8:36 AM, DAN MUELLER <dan.mueller@trnswrks.com>wrote: > > > Good Morning, > > > > IDS 11.50.FC5 > > AIX 5.3 > > > > I am just beginning to take advantage of the compression feature. All went > > well testing but when I went to a prod server I ran into a problemwith the > > shrink option. As soon as it started it failed with the following message > > in > > the online.log: > > > > 20:39:06 rscCommand: This operation cannot run concurrently with an > > archive.isfd = 12, table = 'fin2:"informix".maintenance_log', iserrno 147 > > 20:39:06 ERROR fin2:"informix".maintenance_log: rscCommand failed for > > partnum > > 2097386 > > 20:39:06 Shrink operation failed for fin2:"informix".maintenance_log, > > iserrno > > 0 > > 20:39:06 ERROR: admin_fragment_command('fragment compress repack shrink > > ','2097386') failed > > > > >From the error, I obviously cannot run the shrink option while an archive > > is > > active but my question is what happens when I restart the shrink? Does it > > somehow take off where it failed or restart from the beginning? When I > > tested > > this in dev, it took about 3 days to compress, repack, & shrink a fragment > > in > > this partition. If this behavior repeats itself in prod, i am looking at > > not > > being able to run an archive for 3 days??? > > > > Obviously I have something to take back to the dev box and test but I would > > like any insight that anyone may already have on this. > > > > Thanx, > > Dan > > > > > > > > > ******************************************************************************* > > Forum Note: Use "Reply" to post a response in the discussion forum. > > > > > > --001636c5c1eba9606a0499bb86e8 > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. >