KAIO assert failure on HP-UX 11.0 / IDS 7.31 fc4
Posted in 2000
Topics: Performance & Tuning, Error Codes & Troubleshooting, Platform-Specific Issues, Versions, Editions & End-of-Life
When I try to initialize IDS shared memory with KAIOON=1, I get the
following errors:
Event alarms enabled. ALARMPROG = '/informix/etc/log_full.sh'
10:02:17 DR: DRAUTO is 0 (Off)
10:02:17 Informix Dynamic Server Version 7.31.FC4 Software SerialNumber
10:02:17 hpkaioaddseg: ASYNC_ADDSEG failed, errno = 14
10:02:17 Assert Failed: kaiothread() ERROR
10:02:17 Informix Dynamic Server Version 7.31.FC4
10:02:17 Who: Session(0, @, 0, 0)
Thread(63, kaio, 0, 9)
File: kaio.c Line: 2121
10:02:17 stack trace for pid 3107 written to /tmp/af.427baf8
10:02:30 See Also: /tmp/af.427baf8
10:02:30 kaio.c, line 2121, thread 63, proc id 3107, kaiothread()
ERROR.
10:02:30 PANIC: Attempting to bring system down
10:02:30 semctl: errno = 22
I have the latest HP patches on the system, and the /dev/async driver
loaded and created in /dev. I can bring IDS up without KAIO
enabled...but would rather use it for the performance gain.
Any ideas?
Thanks,
Russ Kahler
ERP Systems Administrator
The Andersons
Maumee, Ohio
Sent via Deja.com http://www.deja.com/
Before you buy.
Russ,
Arghh.. I tired from this bug. The bug is in 7.30 UC6 and 7.30UC8,
Now it looks like 7.31 is infected too ;(
------------------------------------------------------------------
Bug: 110290 KAIO ON HP FAILS WITH THE FOLLOWING ERROR HPKAIOADDSEG:
ASYNC_ADDSEG FAILED, ERRNO = 12, ASSERT FAILED: KAIOTHREAD() ERROR
Description:
On HP-UX 10.20 KAIO is failing when trying to initialize an
instance with a shared (Resident + Virtual) SHM SEG of size
93224960 , even though SHMMAX is set to 134217728. The same
configuration works just fine in 7.24.UC7, also with a smaller
shared memory segment KAIO works fine (i.e. SHM 82984960)
This is similar to what was reported in BUG 104595 but in
this case we have a single shared memory segment and the
SHMMAX is set to a value greater in size than the size of
the shared memory segment the engine allocated.
---------------------------------------------------------------
There was a general bug description, but I ran into the problem
with different amount of SHMSEG and ERRNO. Anyway
Informix Tech Support sends the description.
You can only ask Informix about producing a patch for you or
not use KAIO.
Eugene Nechayev
In article <86kgvf$grs$1@nnrp1.deja.com>,
russ_kahler@andersonsinc.com wrote:
> When I try to initialize IDS shared memory with KAIOON=1, I get the
> following errors:
>
> Event alarms enabled. ALARMPROG = '/informix/etc/log_full.sh'
> 10:02:17 DR: DRAUTO is 0 (Off)
> 10:02:17 Informix Dynamic Server Version 7.31.FC4 Software Serial> Number
> 10:02:17 hpkaioaddseg: ASYNC_ADDSEG failed, errno = 14
> 10:02:17 Assert Failed: kaiothread() ERROR
> 10:02:17 Informix Dynamic Server Version 7.31.FC4
> 10:02:17 Who: Session(0, @, 0, 0)
> Thread(63, kaio, 0, 9)
> File: kaio.c Line: 2121
> 10:02:17 stack trace for pid 3107 written to /tmp/af.427baf8
> 10:02:30 See Also: /tmp/af.427baf8
> 10:02:30 kaio.c, line 2121, thread 63, proc id 3107, kaiothread()
> ERROR.
> 10:02:30 PANIC: Attempting to bring system down
> 10:02:30 semctl: errno = 22>
> I have the latest HP patches on the system, and the /dev/async driver
> loaded and created in /dev. I can bring IDS up without KAIO
> enabled...but would rather use it for the performance gain.
>
> Any ideas?
>
> Thanks,
>
> Russ Kahler
> ERP Systems Administrator
> The Andersons
> Maumee, Ohio
>
> Sent via Deja.com http://www.deja.com/
> Before you buy.
>
Sent via Deja.com http://www.deja.com/
Before you buy.