How to DROP unlogged table on RSS?
Posted in 2018
Topics: Server Administration
IDS 12.10.FC3 Solaris 10 1/13 I have an unlogged table in an RSS. I would like to DROP it. But, I cannot access it to DROP it. I can see it in Server Studio and dbAccess, but cannot execute a DROP TABLE command on it (because it is inaccessible because it is raw). I have already DROPed it from the primary. How can I get rid of it on the RSS? Thank you. DG
P.S. The problem is that I want to dbexport that database. But, I cannot run
dbexport because it errors out when it comes to the unlogged table. But, I
cannot drop it because it errors out when trying to access it (i.e., run the
DROP command).
Sort of like, "I can't get there from here".
Is the only solution to DROP the entire database, and start RSS completely
from the beginning? Surely there must be a way to get rid of that table.
Dropping the RAW table on the primary should have been replicated to the RSS secondary. Have you dropped the table while the the "STOP_APPLY 1" was active on the RSS?
The fault was totally mine.
Indeed Mr. Marques nailed it.
I had set STOP_APPLY to 1 so that I could do a dbexport. After dbexport
crashed because it encountered the raw table, I failed to reset the STOP_APPLY
before DROPing the table in the primary. So, naturally, it didn't DROP in the
RSS. And, of course, no operations in the secondary could touch it.
Thank you.
DG