Onstat
Posted in 2000
Topics: Installation, Setup & Upgrades
Hi all,
I recently installed Informix dynamic server 7.31.UC6 on HP UX 11.0
I am getting an error while running onstat.
"Changing data structure forced command termination. "
can someone interpret this message for me and tell me the action to be
taken.
Thanks,
Srini
Have you set shared memory parameters from
$INFORMIXDIR/release/en_us/0333/IDS_7.3 ?
Also check $INFORMIXDIR.
It happens sometimes when server is very busy. Isn't it? Have you run
onstat again? It should work properly.
Srinivas Sreekumar wrote:
> Hi all,
>
> I recently installed Informix dynamic server 7.31.UC6 on HP UX 11.0
>
> I am getting an error while running onstat.
>
> "Changing data structure forced command termination. "
>
> can someone interpret this message for me and tell me the action to be
> taken.
>
> Thanks,
> Srini
I've seen it while waiting for it to come on-line. After that I've never
noticed it.
In article <8fov42$okt$1@news.xmission.com>, Srinivas Sreekumar
<SRINIVAS_SK@inf.com> writes
>
>Hi all,
>
>I recently installed Informix dynamic server 7.31.UC6 on HP UX 11.0
>
>I am getting an error while running onstat.
>
>"Changing data structure forced command termination. "
>
>can someone interpret this message for me and tell me the action to be
>taken.
>
>Thanks,
>Srini
Andrew Lennard andy@kontron.demon.co.uk
Srinivas Sreekumar wrote:
>
> Hi all,
>
> I recently installed Informix dynamic server 7.31.UC6 on HP UX 11.0
>
> I am getting an error while running onstat.
>
> "Changing data structure forced command termination. "
>
> can someone interpret this message for me and tell me the action to be
> taken.
Used to happen in 7.2x all the time and the problem was supposed to have
been fixed in 7.3x, hmmm. It basically means that onstat was following
a chain of rows from releated SMI tables (or their shared memory
equivalents, and some link became broken by a dynamic operation of the
server. To avoid slowing the engine down onstat does not try to take any
locks or latches on the data structures on which it reports so this is
possible but rare. Is it happening all the time or only occassionally?
If the all the time it may be a new bug. If only occassionally just try
the onstat again in a few minutes when things have quieted down a bit.
Art S. Kagel