Robert,
I don't see where the problem is :-)
>
> I am trying to run this statement with Informix 7.10:
>
> INSERT INTO a
> SELECT 1, b.* FROM b>
> B is view that is a join between table A and another. When
So when you insert into table a, you are by definition updating view b...
> this statement is run, I get this error:
>
> -360: Cannot modify table or view used in subquery.>
> Of course the text of the error is correct (the view _is_
> readonly), but I'm not updating the view, so why does it
> care?
Because you are updating a table used in the query (ignore the words 'or view'
in the error message).
> Of course there are workarounds, but is this a fug or a
> beature?
I'd say Informix was doing what it was supposed to do.
Cheers,
Richard.
-----------------------------------------------------------------
| _________ | Richard Thomas |
| / /_______| | r.thomas@csl.gov.uk |
| / /__/ | |
| /_/ | TRIGGER happy ;-) |
| | |
-----------------------------------------------------------------