Re: HDR & Logical Logs and Network failure
Posted in 2000
En Pankaj va escriure el dia 5 Jul 2000, a les 15:45:
> Hi All ,
>
> Need some help. Solaris 5.6 & IDS 7.30.UC6 & HDR . Need it quickly as I only
> found out about the network going down about 2 minutes ago and never got to
> test this scenario out.
>
> Does anyone know what happens when there is a Network failure and the
> Primary Server cannot Talk to the Secondary server, But no damage has
> occurred to either, and a number of logical logs on the primary are
> backed-up to tape during the network down time ?
>
The primary server go run Ok.
The secondary server go run Ok.
The backup of logical logs don't afect to the replication except if you gen more logical logs then the logical logs
number defined in your engine.
> When the network connection comes back up :-
>
> 1.Can the secondary re-sync itself with the primary as you have written a
> number of logs to tape during the network break ?
> 2. or Does the secondary require the logical log tape from the primary to
> roll forward the logical logs and if it does require the logical logs do you
> stop logical logging on the primary during this time ( this last one I
> would have thought so but I have know be wrong).
>
The servers will be re-sync if the logical logs generated during the net failure are less than the total logical logs
number.
If you gen more logical logs than the logical logs number defined in your system (primary box) you shoult be restart
the HDR like the first time (ontape -p on secondary box, apply logical logs with ontape -l and the two boses wil be
re-sync after this operations)
> Whew !!!
> Cheers for you help.
>
> Pankaj
>
>
Sorry for my poor english.
---------------------------------------
Isidre PONS ROCA
BASE - Gesti' d'Ingressos Locals
(Diputacio de Tarragona)
Servei de Sistemes de Informacio
Av President Lluis Companys 12-C
43005 - Tarragona
SPAIN
Tel # +34 977 236731
Fax # +34 977 227302
http://www.altanet.org
ipons@dtgna.altanet.org
---------------------------------------