Return Code 139
Posted in 2004
Topics: Logging & Checkpoints
Can anyone tell what should I do ? Thanks. I am running Informix Dynamic Server Version 7.30.UC2. on SCO 5.0.6 When check on my online.log I found 09:12:52 Process exited with return code 139: /bin/sh /bin/sh -c /informix/comp iler/ids730/etc/log_full.sh 2 23 "Logical Log 28 Complete." "Logical Log 28 Comp lete." When do a finderr 139, it tell to increase my LOGSMAX size even I increase it from 12 to 15 it still having this error. Onstat -l address number flags uniqid begin size used %used 8204de40 1 U-B---- 25 10053f 2560 2560 100.00% 8204de5c 2 U-B---- 26 100f3f 2560 2560 100.00% 8204de78 3 U------ 27 10193f 2560 2560 100.00% 8204de94 4 U------ 28 10233f 2560 2560 100.00% 8204deb0 5 U---C-L 29 102d3f 2560 18 0.70% 8204decc 6 U-B---- 18 10373f 2560 2560 100.00% 8204dee8 7 U-B---- 19 10413f 2560 2560 100.00% 8204df04 8 U-B---- 20 104b3f 2560 2560 100.00% 8204df20 9 U-B---- 21 10553f 2560 2560 100.00% 8204df3c 10 U-B---- 22 105f3f 2560 2560 100.00% 8204df58 11 U-B---- 23 10693f 2560 2560 100.00% 8204df74 12 U-B---- 24 10733f 2560 2560 100.00%
Hi,
the error code 139 had been returned by the script log_full.sh, therefor it
is related
to the onbar process. This script is doing a log backup when the logical log
is full.
error 139 is as follows:
BAR_BAD_VERSION 0x8b
There is no matching entry in table 'bar_version' (sysutils database) for
the
version number that is delivered by the Storage manager during the ON-Bar
initialization. Usually this is caused by a problem with the initialization
of the Storage manager.
Which Storage Manager are you using?
Regards
Diane Lavoie
Administrateur de base de données/Database Administrator
Infrastructure et applications Corporatives/Insfrastructure and Corporate
Solutions
Domtar Inc.
' 514-848-5975
* diane.lavoie@domtar.com <mailto:diane.lavoie@domtar.com>
-----Original Message-----
From: CHUA TECK WUI [mailto:chuatw@starhub.net.sg]
Sent: Saturday, January 03, 2004 8:40 PM
To: ids@iiug.org
Subject: Return Code 139 [2401]
Can anyone tell what should I do ? Thanks.
I am running Informix Dynamic Server Version 7.30.UC2. on SCO 5.0.6
When check on my online.log I found
09:12:52 Process exited with return code 139: /bin/sh /bin/sh -c
/informix/comp
iler/ids730/etc/log_full.sh 2 23 "Logical Log 28 Complete." "Logical Log 28
Comp
lete."
When do a finderr 139, it tell to increase my LOGSMAX size even I increase
it from 12 to 15 it still having this error.
Onstat -l
address number flags uniqid begin size used %used
8204de40 1 U-B---- 25 10053f 2560 2560 100.00%
8204de5c 2 U-B---- 26 100f3f 2560 2560 100.00%
8204de78 3 U------ 27 10193f 2560 2560 100.00%
8204de94 4 U------ 28 10233f 2560 2560 100.00%
8204deb0 5 U---C-L 29 102d3f 2560 18 0.70%
8204decc 6 U-B---- 18 10373f 2560 2560 100.00%
8204dee8 7 U-B---- 19 10413f 2560 2560 100.00%
8204df04 8 U-B---- 20 104b3f 2560 2560 100.00%
8204df20 9 U-B---- 21 10553f 2560 2560 100.00%
8204df3c 10 U-B---- 22 105f3f 2560 2560 100.00%
8204df58 11 U-B---- 23 10693f 2560 2560 100.00%
8204df74 12 U-B---- 24 10733f 2560 2560 100.00%
All,
I think the error code is not returned by onbar or the XBSA library, but
the OS or the shell .
If it was an XBSA error or onbar error , the backup would have failed. I
infer the backup did succeed,
only the shell returned a rc 139.
In this case finderr won't give you a clue.
What storage manager do you use ?
Maybe there is an incompatibility between the your XBSA library, onbar and
the OS .
In any case, the first thing I'd do is to verify you are able to restore
the backup (do an
imported restore to a test machine!)
Apart from that - 7.30 is not supported naymore as far as I know.
I strongly suggest to think about an upgrade to 7.31.
With kind regards
Tilman
--
Tilman Model-Bosch
IBM Data Managment Solutions, Informix Advanced Support
c\\\\o SAP AG
TECHDEV 05
Neurrotstr.16
69190 Walldorf
"Lavoie, Diane"
<diane.lavoie@dom To: ids@iiug.org
tar.com> cc:
Sent by: Subject: RE: Return Code 139 [2406]
forum.subscriber@
iiug.org
01/05/2004 02:52
PM
Hi,
the error code 139 had been returned by the script log_full.sh, therefor it
is related
to the onbar process. This script is doing a log backup when the logical
log
is full.
error 139 is as follows:
BAR_BAD_VERSION 0x8b
There is no matching entry in table 'bar_version' (sysutils database) for
the
version number that is delivered by the Storage manager during the ON-Bar
initialization. Usually this is caused by a problem with the
initialization
of the Storage manager.
Which Storage Manager are you using?
Regards
Diane Lavoie
Administrateur de base de données/Database Administrator
Infrastructure et applications Corporatives/Insfrastructure and Corporate
Solutions
Domtar Inc.
' 514-848-5975
* diane.lavoie@domtar.com <mailto:diane.lavoie@domtar.com>
-----Original Message-----
From: CHUA TECK WUI [mailto:chuatw@starhub.net.sg]
Sent: Saturday, January 03, 2004 8:40 PM
To: ids@iiug.org
Subject: Return Code 139 [2401]
Can anyone tell what should I do ? Thanks.
I am running Informix Dynamic Server Version 7.30.UC2. on SCO 5.0.6
When check on my online.log I found
09:12:52 Process exited with return code 139: /bin/sh /bin/sh -c
/informix/comp
iler/ids730/etc/log_full.sh 2 23 "Logical Log 28 Complete." "Logical Log 28
Comp
lete."
When do a finderr 139, it tell to increase my LOGSMAX size even I increase
it from 12 to 15 it still having this error.
Onstat -l
address number flags uniqid begin size used %used
8204de40 1 U-B---- 25 10053f 2560 2560 100.00%
8204de5c 2 U-B---- 26 100f3f 2560 2560 100.00%
8204de78 3 U------ 27 10193f 2560 2560 100.00%
8204de94 4 U------ 28 10233f 2560 2560 100.00%
8204deb0 5 U---C-L 29 102d3f 2560 18 0.70%
8204decc 6 U-B---- 18 10373f 2560 2560 100.00%
8204dee8 7 U-B---- 19 10413f 2560 2560 100.00%
8204df04 8 U-B---- 20 104b3f 2560 2560 100.00%
8204df20 9 U-B---- 21 10553f 2560 2560 100.00%
8204df3c 10 U-B---- 22 105f3f 2560 2560 100.00%
8204df58 11 U-B---- 23 10693f 2560 2560 100.00%
8204df74 12 U-B---- 24 10733f 2560 2560 100.00%