Unable to run Informix SQL on UNIX !?!?!
Posted in 1999
Topics: General Discussion
We've been running Informix SQL on and from our UNIX server for a while now. However, after a recent power cut I have been unable to access any of the databases previously created. We run it with the 'isql' command, yet informix detects doesnt detect any databases. The error message states that is a 'daemon error' Any suggestions? Thanks in advance Mark.G happyhim@mweb.co.za
Mark Galliers wrote: > > We've been running Informix SQL on and from our UNIX server for a while now. > However, after a recent power cut I have been unable to access any of the > databases previously created. We run it with the 'isql' command, yet > informix detects doesnt detect any databases. The error message states that > is a 'daemon error' Not enough information to help you. What version of Informix? SE, OL, IDS, XPO, UDO? Ver 4.xx, 5.xx, 6.xx, 7.xx? What version of ISQL? Is the engine online? Is the listener (for OL[45].xx or SE versions) online? Help us and we can help you. Art S. Kagel
Mark Galliers wrote: > > We've been running Informix SQL on and from our UNIX server for a > while now. However, after a recent power cut I have been unable to > access any of the databases previously created. We run it with the > 'isql' command, yet informix detects doesnt detect any databases. > The error message states that is a 'daemon error' As Art Kagel said, we don't really have enough information to go on. However, it could be that you need to be running sqlexecd and it was not restarted automatically when you rebooted the machine. This could apply if you use SE, or if you use 5.x or earlier I-Star. -- Jonathan Leffler (jleffler@informix.com, jleffler@earthlink.net) Guardian of DBD::Informix v0.60 -- see http://www.perl.com/CPAN #include <disclaimer.h>