Re: ovlock=56
Posted in 1997
In article <5m39a2$nfu@camel1.mindspring.com>, Larry Foote
<lfoote@pipeline.com> writes
>ogolde@impsat1.com.ar (Oscar Goldes) wrote:
>
>>Hello,
>>running onstat on Informix Online 7.2 I noticed the value
>>ovlock=56
>>after two days up.
>
>>Is this value acceptable? Or should it be 0?
>It is best to prevent lock overflow from occurring during normal
>processing.
>
Agreed - every time ovlocks goes up the session that tries to
exceed the number of available locks gets an error...
>>The value of LOCKS is 60000
>>What happens when a process needs a lock and there are no more available?
The update/insert/delete/select FAILS and an error code is returned to
the apllication.
>I suggest bumping locks up to at least 200000. It takes a little more
1 lock = ~43 bytes therefore 10,000 locks = roughly 1/2 Mb of memory.
Since you are only getting occasional ovlocks I would try 100,000
locks i.e. increase memory usage by 40,000 locks = 2Mb. If you still
get ovlocks then kep increasing by 40,000 until they stop happening.
>memory but not much. If you keep getting lock overflow (ovlock > 0)
>and still have available memory, then make it larger. If a there are
>no more locks available you will get a lock overflow and something
>will usually get rolled back. If you are doing a large update or
>insert to a table, I would lock the table first.
>
Agreed - LOCK TABLE tab1 IN EXCLUSIVE MODE first.
>>I have also found
>>lockwaits=245
>
>>Does this refer to the number of times a process had to wait for a locked
>>resource, or the number of times it had to wait for an available lock?
>I believe this indicates the number of times a process has had to wait
>for a locked table or a locked row. If there are no available locks
>you will get a lock overflow.
>
Correct - it is the time of times a process had to wait for a locked
resource.
>>Thanks in advance.
>>-- Oscar Goldes
>>-- Orden Argentina SA
>
>
--
David Williams