Re: oninit: Fatal error in shared memory creation
Posted in 1999
Topics: Storage & Space Management, Platform-Specific Issues
Regardless of the original reason for failing to come up (which may already
be fixed) you need to delete remaining shared memory segments. You can
calculate the unique key for your server by calculating (in hex) (SERVERNUM
* 10000)+52564801; in your case you obviously left SERVERNUM as 0 when
initializing OnLine. I assume that you have no other instances of OnLine
running; remember that each instance must have a unique server number.
(SERVERNUM is found in your Online configuration file.) You can then use
the resultant number to (as root) use the ipcrm command and remove the
offending segment(s). Note that you may want to use ipcs -m and look for
other segments with the owner root (or informix) and informix as the group.
These are likely other segments taht will have to be freed before OnLine
will live up to its name.
HTH,
David
"Kevin M. Carroll" <aa664@seorf.ohiou.edu> on 01/07/99 01:32:14 PM
Please respond to "Kevin M. Carroll" <aa664@seorf.ohiou.edu>
To: informix-list@iiug.org
cc: (bcc: David Coburn/ISG/WVUS/WorldVision)
Subject: Re: oninit: Fatal error in shared memory creation
The most recent entries in the online.log file report:
shmget: [EEXIST][17]: key 52564801: shared memory already exists
mt_shm_init: can't create resident segment
The first error however was:
shmat: [EMFILE][24]: out of shared memory segments, check system SHMSEG
mt_shm_init: can't create virtual segment
Other possibly pertinent info: I am creating a root space of about 1GB on
an
18GB disk. Any thoughts? Thanks in advance.
Kevin
"Kevin M. Carroll" wrote:
> Can someone please point me in some direction on this? I am trying to
> set up Online Workgroup Server v7.2+ on a Sun Ultra2 running Solaris
> 2.6. We are attempting to use a cooked file (which seems to be generated
> fine for the root). I am configuring through
> onmonitor-->Parameters-->Initialize. I make it all the way to the end of
> the process until it fianlly says Warning.... root dbspace will be
> initialized. Do you want to continue? (y/n)
> Initializing, please wait ...
>
> oninit: Fatal error in shared memory creation
David,
Thanks for your time and your help. I removed the offending segment, but now
I'm seeing another error:
shmat: [EIVAL][22]: shared memory base address illegal
using 0xa100000, needs 0xef400000
mt_shm_init: can't create resident segment
Thanks again for your help. I am usually pretty good about searching through
documentation to debug stuff like this, but I couldn't find anything. Not even
on SHMSEG or SHMMAX. If you can point me to something that would help, please
do. Thanks for your help.
Kevin
David Coburn wrote:
> Regardless of the original reason for failing to come up (which may already
> be fixed) you need to delete remaining shared memory segments. You can
> calculate the unique key for your server by calculating (in hex) (SERVERNUM
> * 10000)+52564801; in your case you obviously left SERVERNUM as 0 when
> initializing OnLine. I assume that you have no other instances of OnLine
> running; remember that each instance must have a unique server number.
> (SERVERNUM is found in your Online configuration file.) You can then use
> the resultant number to (as root) use the ipcrm command and remove the
> offending segment(s). Note that you may want to use ipcs -m and look for
> other segments with the owner root (or informix) and informix as the group.
> These are likely other segments taht will have to be freed before OnLine
> will live up to its name.
>
> HTH,
>
> David
>
> "Kevin M. Carroll" <aa664@seorf.ohiou.edu> on 01/07/99 01:32:14 PM
>
> Please respond to "Kevin M. Carroll" <aa664@seorf.ohiou.edu>
>
> To: informix-list@iiug.org
> cc: (bcc: David Coburn/ISG/WVUS/WorldVision)
> Subject: Re: oninit: Fatal error in shared memory creation
>
> The most recent entries in the online.log file report:
>
> shmget: [EEXIST][17]: key 52564801: shared memory already exists
> mt_shm_init: can't create resident segment
>
> The first error however was:
>
> shmat: [EMFILE][24]: out of shared memory segments, check system SHMSEG
> mt_shm_init: can't create virtual segment
>
> Other possibly pertinent info: I am creating a root space of about 1GB on
> an
> 18GB disk. Any thoughts? Thanks in advance.
>
> Kevin
>
> "Kevin M. Carroll" wrote:
>
> > Can someone please point me in some direction on this? I am trying to
> > set up Online Workgroup Server v7.2+ on a Sun Ultra2 running Solaris
> > 2.6. We are attempting to use a cooked file (which seems to be generated
> > fine for the root). I am configuring through
> > onmonitor-->Parameters-->Initialize. I make it all the way to the end of
> > the process until it fianlly says Warning.... root dbspace will be
> > initialized. Do you want to continue? (y/n)
> > Initializing, please wait ...
> >
> > oninit: Fatal error in shared memory creation
Kevin M. Carroll wrote: > > David, > > Thanks for your time and your help. I removed the offending segment, but now > I'm seeing another error: > > shmat: [EIVAL][22]: shared memory base address illegal > using 0xa100000, needs 0xef400000 > mt_shm_init: can't create resident segment > > Thanks again for your help. I am usually pretty good about searching through > documentation to debug stuff like this, but I couldn't find anything. Not even > on SHMSEG or SHMMAX. If you can point me to something that would help, please > do. Thanks for your help. SHMSEG and SHMMAX are Solaris kernel configuration parameters you need to increase the values of these in the kernel build config files, or add them there if they are absent and assumed to default, and then build and reboot a new kernel. Your system administrator will know how to do this. You can make SHMMAX 2GB so that ANY size segment can be created and then you only have to worry about SHMSEG if other applications on the machine will be using shared memory extensively. You may also need to adjust the kernel parameter that determine the amount or percent of shared memory that may be marked RESIDENT so you can turn on the RESIDENT parameter in the ONCONFIG file. Art S. Kagel
In article <36963763.65B9@bloomberg.net>, Art S. Kagel <kagel@bloomberg.net> writes >Kevin M. Carroll wrote: >> >> David, >> >> Thanks for your time and your help. I removed the offending segment, but now >> I'm seeing another error: >> >> shmat: [EIVAL][22]: shared memory base address illegal >> using 0xa100000, needs 0xef400000 >> mt_shm_init: can't create resident segment >> >> Thanks again for your help. I am usually pretty good about searching through >> documentation to debug stuff like this, but I couldn't find anything. Not even >> on SHMSEG or SHMMAX. If you can point me to something that would help, please >> do. Thanks for your help. > Check under $INFORMIXDIR/release for files containing release notes (May be in $INFORMIXDIR/release/en_us/0333 or $INFORMIXDIR/release/ows).. > >Art S. Kagel -- David Williams