Re: Listener-thread err 25572 oserr=233 system error=233
Posted in 2003
Here is the message from online log.
- Back
17:08:02 listener-thread: err = -25573: oserr = 233:errstr = : Network driver
cannot accept a connection on the port.
System error = 233.
17:14:56 Checkpoint Completed: duration was 0
seconds.
17:14:56 Checkpoint loguniq 48159, logpos 0xd77100
17:28:34 listener-thread: err = -25573: oserr = 233:errstr = : Network driver
cannot accept a connection on the port.
System error = 233.
--- Michael Mueller <michael.mueller01@kay-mueller.de>
wrote:
> Error 233 can be found in file
>
> /usr/include/sys/errno.h
>
> On HP it means:
>
> #define ENOBUFS 233 /* No buffer space
> available */
>
> This sounds indeed like some os resource problem. HP
> should be able to
> tell you more.
>
> Netstat -a will show you the port numbers already in
> use. If you try to
> use a port with online that is in use by some other
> process running on
> your machine, you would get 25572. But I don't think
> that this is your
> problem.
>
> What still confuses me is that you seem to get this
> error while the
> server is running. I would expect that this only
> happens when online is
> started. After the error the online port should be
> unusable until you
> reboot it successfully. Can you post a piece of your
> online message log?
>
> Michael
>
>
> Vineet Mehrotra wrote:
> > it is onsoctcp and the problem could happen
> > anytime..no fixed trends....
> > and what good information i can get from netstat
> -a ,
> > if you can write in detail would be very useful in
> > daignosis of the problem....this is not a show
> stopper
> > , only thing is no new connection initiates for
> the
> > instance for a moment and those already connected
> keep
> > working as it is...
> > --- Michael Mueller
> <michael.mueller@kay-mueller.de>
> > wrote:
> >
> >>Could you provide us with some more details? What
> >>os? When does it
> >>happen? Which protocol?
> >>
> >>If it happens when online is booted on a tli or
> soc
> >>port, it's probably
> >>because the port is in use by someone else. Check
> >>netstat -a output.
> >>
> >>Michael
> >>
> >>Vineet Mehrotra wrote:
> >>
> >>>Informix Dynamic Server 7.31UD2R1
> >>>on HP-UX 11.0
> >>>
> >>>Hi All,
> >>>
> >>>Has anybody has any definitive answer for this
> >>>problem.
> >>>
> >>>Where are lacking in resources in terms of
> >>
> >>OS/Database
> >>
> >>>or somehting else?
> >>>
> >>>What Kernel params could be responsible for this?
> >>>
> >>>What values should be kept to avoid these
> >>
> >>problems?
> >>
> >>>Thanks,
> >>>
> >>>Vineet
> >>>
> >>>__________________________________
> >>>Do you Yahoo!?
> >>>SBC Yahoo! DSL - Now only $29.95 per month!
> >>>http://sbc.yahoo.com
> >>>sending to informix-list
> >>>
> >>
> >>
> >>--
> >>
> >>=== Michael Mueller ==================
> >>Tel. + 49 8171 63600
> >>Fax. + 49 8171 63615
> >>Web: http://www.mm.kay-mueller.de
> >> http://www.planets.kay-mueller.de
> >>======================================
> >>
> >
> >
> >
> > __________________________________
> > Do you Yahoo!?
> > SBC Yahoo! DSL - Now only $29.95 per month!
> > http://sbc.yahoo.com
> >
>
>
> --
>
> === Michael Mueller ==================
> Tel. + 49 8171 63600
> Fax. + 49 8171 63615
> Web: http://www.mm.kay-mueller.de
> http://www.planets.kay-mueller.de
> ======================================
>
> sending to informix-list
__________________________________
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com
sending to informix-list