Re: SHMTOTAL
Posted in 2000
Topics: General Discussion
Hi,
The SHMTOTAL sets the limit on the amount of virtual memory IDS will
get from the OS. The value of SHMTOTAL should be
SHMTOTAL >= (size of resident) + (initial virtual segment size)
Increase your SHMTOTAL or decrease the sizes of your resident and/or
virtual shared memory.
Don
"Manel Falc' i Aige" wrote:
>
> Hi,
> I want to delimiter SHMTOTAL because I don't have much memory.
> hence, I only want one Virtual segment.
>
> now, this messages appears on online.log
>
> 19:13:12 size of resident + virtual segments 23437312 + 33308672 >> 51200000
> total allowed by configuration parameter SHMTOTAL
>
> Can any thing work wrong ? Which is the minim size allowed ?
>
> Thanks,
> Manel
Ok, I set SHMTOTAL >= (size of resident) + (initial virtual segment
size)
but,
What will it happen if it need a new segment that overflows SHMTOTAL ?
in fact, I got these errors:
----- User: dolors -----
Date: 13/07/2000 Time: 11:46:24
Program error at 'pedven.4gl', line number 492.
SQL statement error number -566.
Cannot initiate sort.
SYSTEM error number -116.
ISAM error: cannot allocate memory.
Date: 13/07/2000 Time: 11:46:24
----- User: noel -----
Date: 13/07/2000 Time: 12:24:50
Program error at 'r_pedcom.4gl', line number 151.
SQL statement error number -208. Memory allocation failed during query processing.
Date: 13/07/2000 Time: 12:24:50
hence, better SHMTOTAL=0 ?
Manel
On Wed, 12 Jul 2000 16:57:51 -0400, Don Ignacio
<dignacio@openratings.com> wrote:
>
>Hi,
>
>The SHMTOTAL sets the limit on the amount of virtual memory IDS will
>get from the OS. The value of SHMTOTAL should be
>
> SHMTOTAL >= (size of resident) + (initial virtual segment size)
>
>Increase your SHMTOTAL or decrease the sizes of your resident and/or
>virtual shared memory.
>
>
>Don
>
>"Manel Falcó i Aige" wrote:
>>
>> Hi,
>> I want to delimiter SHMTOTAL because I don't have much memory.
>> hence, I only want one Virtual segment.
>>
>> now, this messages appears on online.log
>>
>> 19:13:12 size of resident + virtual segments 23437312 + 33308672 >>> 51200000
>> total allowed by configuration parameter SHMTOTAL
>>
>> Can any thing work wrong ? Which is the minim size allowed ?
>>
>> Thanks,
>> Manel
You can't, that's what SHMTOTAL is for. SHMTOTAL limits the total
amount of shared memory that is usable by Informix, so if Informix wants
a new segment, it first checks to see if that will cause it to go over
SHMTOTAL. If it will, Informix makes do with what it has.
In article <396ed431.5503226@news.bcn.ttd.net>,
manel@semic.es (Manel Falc' i Aige) wrote:
> Ok, I set SHMTOTAL >= (size of resident) + (initial virtual segment
> size)
> but,
> What will it happen if it need a new segment that overflows SHMTOTAL ?
>
> in fact, I got these errors:
> ----- User: dolors -----
> Date: 13/07/2000 Time: 11:46:24
> Program error at 'pedven.4gl', line number 492.
> SQL statement error number -566.
> Cannot initiate sort.
> SYSTEM error number -116.
> ISAM error: cannot allocate memory.
> Date: 13/07/2000 Time: 11:46:24
> ----- User: noel -----
> Date: 13/07/2000 Time: 12:24:50
> Program error at 'r_pedcom.4gl', line number 151.
> SQL statement error number -208.> Memory allocation failed during query processing.
> Date: 13/07/2000 Time: 12:24:50
>
> hence, better SHMTOTAL=0 ?
>
> Manel
>
> On Wed, 12 Jul 2000 16:57:51 -0400, Don Ignacio
> <dignacio@openratings.com> wrote:
>
> >
> >Hi,
> >
> >The SHMTOTAL sets the limit on the amount of virtual memory IDS will
> >get from the OS. The value of SHMTOTAL should be
> >
> > SHMTOTAL >= (size of resident) + (initial virtual segment size)
> >
> >Increase your SHMTOTAL or decrease the sizes of your resident and/or
> >virtual shared memory.
> >
> >
> >Don
> >
> >"Manel Falc' i Aige" wrote:
> >>
> >> Hi,
> >> I want to delimiter SHMTOTAL because I don't have much memory.
> >> hence, I only want one Virtual segment.
> >>
> >> now, this messages appears on online.log
> >>
> >> 19:13:12 size of resident + virtual segments 23437312 + 33308672 >> >> 51200000
> >> total allowed by configuration parameter SHMTOTAL
> >>
> >> Can any thing work wrong ? Which is the minim size allowed ?
> >>
> >> Thanks,
> >> Manel
>
>
--
# unrm /
ksh: unrm: not found
# man cpio
Sent via Deja.com http://www.deja.com/
Before you buy.
mars1972@my-deja.com wrote: >You can't, that's what SHMTOTAL is for. SHMTOTAL limits the total >amount of shared memory that is usable by Informix, so if Informix wants >a new segment, it first checks to see if that will cause it to go over >SHMTOTAL. If it will, Informix makes do with what it has. So what happens to the user sessions if the SHMTOTAL has been reached? 1. Will new users be able to connect? 2. Will a session executing a huge DSS query hang? Or will it just give a user an error message saying that it has run out of memory. 3. Will the DSS query run albeit slowly? Thanks Lyzander ----------------------------------------------------------- Got questions? Get answers over the phone at Keen.com. Up to 100 minutes free! http://www.keen.com
In article <17d0ec58.a97c3cb4@usw-ex0105-035.remarq.com>, Zandy <zandymNOzaSPAM@yahoo.com.invalid> writes > > >mars1972@my-deja.com wrote: >>You can't, that's what SHMTOTAL is for. SHMTOTAL limits the >total >>amount of shared memory that is usable by Informix, so if >Informix wants >>a new segment, it first checks to see if that will cause it to >go over >>SHMTOTAL. If it will, Informix makes do with what it has. > >So what happens to the user sessions if the SHMTOTAL has been >reached? >1. Will new users be able to connect? They might be able to, depends if an existing sessions frees up some memory (closes/free a cursor/prepared statement or exits). >2. Will a session executing a huge DSS query hang? Or will it >just give a user an error message saying that it has run out of >memory. It would get an out of memory error >3. Will the DSS query run albeit slowly? > Nope, it would get an error. >Thanks >Lyzander > > > > > > >----------------------------------------------------------- > >Got questions? Get answers over the phone at Keen.com. >Up to 100 minutes free! >http://www.keen.com > -- David Williams
I had also talked to someone at Informix years ago about SHMTOTAL. They said that it was not a good idea to specify it because when Informix got close (don't know details) to having used SHMTOTAL amount of memory that everything got very SLOW and there was no message anywhere indicating the reason for this slowness. I don't know if they've fixed it or not. We always specify SHMTOTAL 0 because we figure why not use all of the memory of the box anyway. If you specify it and hit the limit, then something is going to fail (individual SQL statement). My $0.02, Bill Border Agilent Technologies bill_border@agilent.com Comprehensive Affordable DB Monitor: http://dbamon.com David Williams wrote in message ... >In article <17d0ec58.a97c3cb4@usw-ex0105-035.remarq.com>, Zandy ><zandymNOzaSPAM@yahoo.com.invalid> writes >> >> >>mars1972@my-deja.com wrote: >>>You can't, that's what SHMTOTAL is for. SHMTOTAL limits the >>total >>>amount of shared memory that is usable by Informix, so if >>Informix wants >>>a new segment, it first checks to see if that will cause it to >>go over >>>SHMTOTAL. If it will, Informix makes do with what it has. >> >>So what happens to the user sessions if the SHMTOTAL has been >>reached? >>1. Will new users be able to connect? > > They might be able to, depends if an existing sessions frees > up some memory (closes/free a cursor/prepared statement or > exits). >>2. Will a session executing a huge DSS query hang? Or will it >>just give a user an error message saying that it has run out of >>memory. > It would get an out of memory error > >>3. Will the DSS query run albeit slowly? >> > Nope, it would get an error. > >>Thanks >>Lyzander >> >> >> >> >> >> >>----------------------------------------------------------- >> >>Got questions? Get answers over the phone at Keen.com. >>Up to 100 minutes free! >>http://www.keen.com >> > >-- >David Williams