Re: no remote access with dbaccess
Posted in 2000
Topics: Installation, Setup & Upgrades, Error Codes & Troubleshooting, Server Administration, Networking & sqlhosts Configuration, Versions, Editions & End-of-Life
From: Norbert.Heidbrink@home.of.the.brave.de
>
>I am trying to connect remotely to an Informix Server but I do not make
>it.
>Can anybody give me a hint? I assume this is nothing but a configuration
>problem.
>
>The situation is as follows.
>Server:
>IDS 2000 on Linux.
>The server is up and running and I can do whatever I want as long as I
>use dbaccess locally on the machine on which the server runs.
>
>Excerpt from server-machine's /etc/services:
>informix 5432/tcp # Informix Dynamic
>Server 2000
>
>Excerpt from server-machine's $INFORMIXDIR/etc/sqlhosts:
>sun onsoctcp sun.brave.de informix>
>
>
>Client:
>Linux as well with an installed Server IDS 7.3.
>The Server is NOT RUNNING!
>
>Excerpt from client's $INFORMIXDIR/sqlhosts:
>sun onsoctcp sun.brave.de informix>
>The first attempt to connect from the client by dbaccess yields the
>error message
>"931: Cannot locate informix service/tcp service in /etc/services"
>
>Strange, but OK.
>I add the entry
>"informix 5432/tcp # Informix Dynamic Server 2000"
>to /etc/services of the client machine.
>
>Second try:
>The connection attemp runs for a while and ends up in the error message
>"908: Attempt to connect to database server (sun) failed.
> ISAM error: record is locked.">
>
>What happens? What else do I have to do in order to establish a
>connection to a remote server?
Are the machines trusted by each other? /etc/hosts.equiv
Can you ping? Can you telnet from the client to port 5432 on the server?
What's in your online.log?
________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com
Hello! > Are the machines trusted by each other? /etc/hosts.equiv No, they are not. Do they need to be when I try to connect using a username and password? (Of course, the user does exist on the server machine as well.) > Can you ping? I can. > Can you telnet from the client to port 5432 on the server? telnet connections are refused by the server machine but with tcdump I see that the communication over that port works. > What's in your online.log? Absolutely nothing. No entry that has anything to do with a connection request from the client. Norbert