RE: Can't start IDS 9.3 on RedHat Advanced Server 3.0
Posted in 2004
Ken,
This is know GLIBC/libpthread problem on Linux:
Informix requires 'libpthread.so' containing __on_exit()
function, which, in turn, requires GLIBC containing
GLIBC_PRIVATE section.
IDS 9.3 works fine on RH7.3
Actually, You can try to install another GLIBC
package onto Your existing Linux.
For example, 'glibc-2.2.93-5.i686.rpm' works fine for IDS 9.21+
------------------------------------------
Alexey Sonkin
>
> Dear All:
>
> I try to evaluate the new setting with IDS 9.3 installed on RedHat
> Advanced Server version 3.0.
> The installation procedure goes fine but when I use "oninit -ivy" to
> start Informix , I get the following error message :
>
> >>oninit: relocation error: /var/lib/libpthread.so.0: symbol _h_errno,
> >>version GLIBC_2.0 not defined in file libc.so.6 with link time
> >>reference
>
> It seems like the library version problem , does anyone know how to
> resolve this ? Or I need to reinstall my OS with another version of
> RedHat for compatibility ?
>
> Thanks in advance
>
> Ken
sending to informix-list