RE: onbar coring when backing-up the logical logs of a whole back
Posted in 2004
seeing your log file, it seems like there is some problem with sm_versions
file, you may need to copy the sm_versions file that veritas provides for
informix in $INFORMIXDIR/etc directory.
you may also do the following
1) bounce the engine, clean up the oninit processes, and make sure there are
no hung share memory segment(s)
2) try backing up the instance without the -w option (i.e. use onbar -b -L
0)
3) set BAR_DEBUG to 7 in your onconfig file, make sure BAR_DEBUG_LOG is set
to a file
by doing #3 the onbar process will dump lot of debug information in the file
set by BAR_DEBUG_LOG, the debug messages will help to find the root cause of
the problem....
-----Original Message-----
From: owner-informix-list@iiug.org
[mailto:owner-informix-list@iiug.org]On Behalf Of briceavila@hotmail.com
Sent: Thursday, May 06, 2004 2:17 PM
To: informix-list@iiug.org
Subject: Re: onbar coring when backing-up the logical logs of a whole
back
Not when backing up only the logical logs ("onbar -b -l"). But it
cores when at the logical log backup phase of a whole backup ("onbar
-b -w -L 0").
Brice
"Savio Pinto (s)" <spinto@cap.org> wrote in message
news:<c7dh27$7bt$1@terabinaries.xmission.com>...
> do you get the core file when you just backup the logical logs?
>
> -----Original Message-----
> From: owner-informix-list@iiug.org
> [mailto:owner-informix-list@iiug.org]On Behalf Of briceavila@hotmail.com
> Sent: Wednesday, May 05, 2004 5:04 PM
> To: informix-list@iiug.org
> Subject: onbar coring when backing-up the logical logs of a whole backup
>
>
> I have a customer running Solaris 8, NetBackup 4.5 MP1 and IDS
> 9.40.UC3. When running a whole backup, they can backup their physical
> dbspace data without errors/warnings, but when the backup starts into
> the logical logs we immediately see onbar core:
>
> 2004-05-05 15:27:37 24060 24058 Begin backup logical log 13895.
> 2004-05-05 15:27:37 24060 24058 Successfully connected to Storage
> Manager.
> 2004-05-05 15:28:12 24060 24058 ASSERT: file
> bar_xbsa.ecbarSendData() line 1331 - contact product support
> 2004-05-05 15:28:13 24060 24058 See also: /tmp/core.24060
> 2004-05-05 15:28:24 24060 24058 /ids_9.4/bin/onbar_d complete,
> returning 159 (0x9f)
>
> According to page 11-14 of the Informix Backup and Restore Guide,
> March 2003 Part No. CT1SLNA (the manual for version 9.40) and Informix
> twister article 1053470, onbar return code 159 is:
>
> "0x9f (159) BAR_BUG. A specific check for an unacceptable error
> condition during the execution of ON-Bar failed. This should be
> reported to Technical Support along with the complete contents of the
> BAR_ACT_LOG."
>
> Subsequent manual logical log backups are successful:
>
> 2004-05-05 15:40:40 25756 25754 /ids_9.4/bin/onbar_d -b -l
> 2004-05-05 15:40:40 25756 25754 Warning: BSA version is 1.1.0.This
> version does not match with the version(s) specified in
> /ids_9.4/etc/sm_versions.
> 2004-05-05 15:40:40 25756 25754 Warning: Assuming Generic Storage
> Manager.
> 2004-05-05 15:40:40 25756 25754 Begin backup logical log 13895.
> 2004-05-05 15:40:40 25756 25754 Successfully connected to Storage
> Manager.
> 2004-05-05 15:44:30 25756 25754 Completed backup logical log 13895
> (Storage Manager copy ID: 1 1083769975).
>
> As I understand Informix support is blaming Veritas, though they
> haven't seen the core file. Has anyone seen a similar error, or can
> provide any insight? Any and all responses, including flames, are
> welcome. Thanks in advance.
>
> Brice Avila
> Minneapolis, Minnesota
> sending to informix-list
sending to informix-list