connection to informix 11.7 windows local system
Posted in 2012
Topics: Installation, Setup & Upgrades, Storage & Space Management, Connectivity: ODBC / JDBC / .NET, Server Administration, Security, Permissions & Auditing, Logging & Checkpoints, Networking & sqlhosts Configuration, Platform-Specific Issues
In Informix 11.7X5 installed on Windows as local system account instead of using informix account, while installation user informix is created and added to Informix-Admin group in addition to Computer Administrator login through which informix was installed. It seems it is known issue as specified in ids_win_fixed_and_known_defects_11.70 file in release notes IC78379 [WINDOWS] USER INFORMIX AND GROUP INFORMIX-ADMIN EXIST AFTER CUSTOM INSTALL SPECIFYING LOCAL SYSTEM ACCOUNT What is the work around for this ? Typical install installs it to C:\\\\ where I do not have enough space. Creating additional user informix in Windows wastes lots of space for My Documents and other unwanted stuff. Still if I allow it to create informix account will it allow me to access database when looged in as other user. Will the database service start ? Basically there is volumes of information on Unix setup and dearth of information on windows setup. I am able to create tables and connect to databases and issue after logging as informix. Creating dbspaces, logical logs all is possible as informix. All system databases sysadmin, sysmaster, sysuser, sysutil gets created successfully when I log in as informix. But when I log in as local system account, sysmaster (many times) and always sysadmin database does not get built. Also login informix has been created with blank password. How do I change password of informix account ? Is there any command for this or changing password in windows user accounts work? Will changing password deny access to database for informix also ? Does ixpasswd change password for related services reliably ? Does the problem exist for all versions of 11.7 or will installing 11.7x4 work ? I am not to able to connect to database through OAT. For many of the options like Logs -> Admin Command History Space Administration -> Storage SQL ToolBox -> Schema Browser Following error is seen : Connection Failed. SQLSTATE=HY000, SQLDriverConnect: -387 [Informix][Informix ODBC Driver][Informix]No connect permission. sqlerrm(sysusers) DSN:informix:host=test;service=3001;database=sysadmin;protocol=onsoctcp;server=o l_test Also I am not able to connect through ODBC in Control Panel -> Administrative Tools to this database. JDBC connectivity also not possible. Error shown as "Attempt to connect database server(ol_test) failed". Using the same drivers I am able to connect to other databases on Linux systems. Also their is one new file since 11.7 olservice.log in INFORMIXDIR and previously following errors were observed in it ol_test: Failure in SuMain(): WaitForMultipleObjects(): 0: The operation completed successfully. The problem with OAT, ODBC, JDBC connectivity exists even when logged as informix. I have tried reinstalling twice so I do not think that it might help.
I have 11.70.TC4DE installed on WinVista SP2 and have experienced the same situation as yours, plus sometimes, when I try to connect to the server, it hangs! If you remove the informix windows user account, it won't work.
>In Informix 11.7X5 installed on Windows as local system account instead of >using informix account, while installation user informix is created and added >to Informix-Admin group in addition to Computer Administrator login through >which informix was installed. I just upgraded from TC4 to TC5. Lots of leftover stuff from 4 remains, annoying windows-user informix continues to be added, even though I told it not to do so in the install script, etc. etc.. I had to manually delete "C:\\\\Program Files\\\\IBM" folder and do a search for all other related leftovers to properly install TC5 and edit Windows registry. The instance I had created under TC4 still wouldn't start, so I had to delete it and create a new instance under TC5. Luckily, I had unloaded all the tables and backed up the SQL scripts to another directory.. I think IBM needs to polish up 1170 for Windows!
Yes, IBM needs to give much required polish to Informix 11.7 on Windows. On Linux systems it runs smoothly but is difficult to do the same on Windows. I have found that if you use the ixpasswd utility and change informix password from blank to some value, you are able to connect through ODBC and also in OAT. However, I am still struggling with connectivity via JDBC which is my primary requirement. I was able to connect to Informix 11.5 via JDBC on same machine through same JDBC drivers. Now I am not able to connect either via old drivers nor via new drivers provided during installation. Also now I have to allow an additional user called informix with its My Documents and all unrequested folders. Sadly windows does not have useradd -M option. Hope that some one from IBM or IIUG solves my problems.