Updateable Secondary is unable to update
Posted in 2008
Topics: High Availability & Replication, Versions, Editions & End-of-Life
Hello all,
I am trying to configure the updateable secondary server using IDS 11.50 UC1,
but the problem i am facing is that i am unable to execute the update query on
the secondary server.
Its gives me the following error while execution of the query:
346: Could not update a row in the table.
In the online.log file, it logs the following error:
12:46:00 Encountered problem processing redirected write: Cannot create new
proxy session
Can anyone tell me that what is the issue? and how to fix it. below is the
more information that could help you:
At Primary Server
=================
[root@etp-dev-bkup ~]# onstat -g dri
IBM Informix Dynamic Server Version 11.50.UC1 -- On-Line (Prim) -- Up 17:43:16
-- 152868 KbytesData Replication:
Type State Paired server Last DR CKPT (id/pg) Supports Proxy Writes
primary on ids_net_hd 41 / 1720 NA
DRINTERVAL 30
DRTIMEOUT 30
DRAUTO 0
DRLOSTFOUND /u/informix_11.50/etc/dr.lostfound
DRIDXAUTO 0
ENCRYPT_HDR 0
At Secondary Server
====================
[root@DB-Server ~]# onstat -g dri
IBM Informix Dynamic Server Version 11.50.UC1 -- Updatable (Sec) -- Up
17:24:48 -- 161060 Kbytes
Data Replication:
Type State Paired server Last DR CKPT (id/pg) Supports Proxy Writes
HDR Secondary on ids_net_hdr 41 / 1720 Y
DRINTERVAL 30
DRTIMEOUT 30
DRAUTO 0
DRLOSTFOUND /u/informix_11.50/etc/dr.lostfound
DRIDXAUTO 0
ENCRYPT_HDR 0
I will be waiting for the quick response. Thanks.
Regards,
Omer Saeed Khan
Is there any other message in the online.log prior to the one that you posted? Also, did you check the online.logs from both the primary and the secondary?
Hello Jacques, No i have just verfied and i havent see any error in either of online.log files both at primary and secondary, except the below error: online.log at primary ===================== 12:37:29 Checkpoint Completed: duration was 0 seconds. 12:37:29 Fri May 30 - loguniq 46, logpos 0x7c1018, timestamp: 0x284e79 Interval: 1160 12:37:29 Maximum server connections 1 12:37:29 Checkpoint Statistics - Avg. Txn Block Time 0.000, # Txns blocked 0, Plog used 68, Llog used 1114 online.log at Secondary ======================= 12:40:15 Maximum server connections 0 12:40:15 Checkpoint Statistics - Avg. Txn Block Time 0.000, # Txns blocked 0, Plog used 75, Llog used 0 12:44:53 Encountered problem processing redirected write: Cannot create new proxy session 12:44:53 Encountered problem processing redirected write: Cannot create new proxy session if you need any further info, then let me know, so that i could send you the onconfig & and any other file if required. I will be waiting for your response. Thanks. Omer Saeed Khan
Could you provide info on the type of Operating System and type of Secondary server you are using. Regards, Nilesh ids-bounces@iiug.org wrote on 05/30/2008 03:02:38 AM: > Hello Jacques, > > No i have just verfied and i havent see any error in either of online.log > files both at primary and secondary, except the below error: > > online.log at primary > ===================== > 12:37:29 Checkpoint Completed: duration was 0 seconds. > 12:37:29 Fri May 30 - loguniq 46, logpos 0x7c1018, timestamp: 0x284e79 > Interval: 1160 > > 12:37:29 Maximum server connections 1 > 12:37:29 Checkpoint Statistics - Avg. Txn Block Time 0.000, # Txns blocked 0, > Plog used 68, Llog used 1114 > > online.log at Secondary > ======================= > 12:40:15 Maximum server connections 0 > 12:40:15 Checkpoint Statistics - Avg. Txn Block Time 0.000, # Txns blocked 0, > Plog used 75, Llog used 0 > > 12:44:53 Encountered problem processing redirected write: Cannot create new > proxy session > 12:44:53 Encountered problem processing redirected write: Cannot create new > proxy session > > if you need any further info, then let me know, so that i could send you the > onconfig & and any other file if required. > > I will be waiting for your response. Thanks. > Omer Saeed Khan > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. >
Hello ,
I am using the following OS at both secondary & primary server:
# cat /etc/issue.netRed Hat Enterprise Linux AS release 4 (Nahant Update 4)
I am using the following IDS version and trying to configure the updateable
secondary in the HDR.
IBM Informix Dynamic Server Version 11.50.UC1 -- Updatable (Sec) -- Up 5 days
04:16:07 -- 152868 Kbytes
Let me know in case of any further info needed.
Thanks in advance for your anticipation. i will be waiting for your response.
Regards,
Omer Saeed Khan
Related threads
- Posting from the Informix-list
- Migrating from IDS 9.40.UC6 to 11.50.UC3
- Ip for a network session
- questions onstat -g