Re: Port designations
Posted in 1999
On Thu, Jul 29, 1999 at 04:23:58PM -0400, Red Valsen wrote:
> While installing IDS 7.30.UC2 on Solaris 2.6 on x86, we encountered a
> failure when initializing the instance with the following error messages
> in the Informix message file:
>
> 11:28:37 listener-thread: err = -25572: oserr = 0: errstr = : Network> driver cannot bind a name to the port.
> 11:28:37 Attempting to bring listener thread down
> 11:28:37 PANIC: Attempting to bring system down>
> The sqlhosts file was correctly configured, referencing the right
> instance/protocol/server/service. DBSERVERNAME, SERVERNUM and NETTYPE
> were set correctly in the ONCONFIG file. In /etc/services, service
> "ifmx_tcp" used port "tcp/1525". It wasn't until the port number was
> changed -- to 1526 -- and the box rebooted that Informix came up
> normally. Port 1525 wasn't defined elsewhere in the file.
>
> Why didn't the original port number work? Why did resetting it work?
> Is there a way to get Unix to tell me what ports are currently active?
> Is there a way to "remap" the ports without rebooting e.g., by
> re-instantiating inet.d?
You can see what ports are currently in use using 'netstat -a'
(or netstat -an to get numeric output) command.
You can get out of use a port by stopping the server program that
listens on it. And not all programs listens to TCP ports through inetd.
If this is a program that listen to a port through inetd you just have to
comment the entry for this program in /etc/inetd.conf (or you have to
change the first field port number) and restart inetd by sending it
a HUP signal.
Hope this helps,
Octav
--
Octav Chiriac Phone: (373) 2 22 99 67
NetInfo S.R.L. Fax: (373) 2 21 36 59
Chisinau (373) 2 22 84 88
Moldova, Republic of mailto:com@netinfo-moldova.com