Connection Pool Error in Linux - Work in Windows
Posted in 2004
Topics: Connectivity: ODBC / JDBC / .NET, Platform-Specific Issues
--=======2B2546CE======= Content-Type: text/plain; x-avg-checked=avg-ok-24C6DE2; charset=us-ascii; format=flowed Content-Transfer-Encoding: 8bit Hi We are trying to configure a Connection Pool with Tomcat 5.0. We developed an application that runs in Windows environment but when we migrated to Linux it doesn't work and we got the following message: Exception: org.apache.commons.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory, cause: com.informix.asf.IfxASFException: Attempt to connect to database server (ol_service) failed. We copied all JARs (ifxjdbc) that we used in Windows to Linux, what should be the reason of this error? Thanks a lot Fabio --=======2B2546CE======= Content-Type: text/plain; charset=us-ascii; x-avg=cert; x-avg-checked=avg-ok-24C6DE2 Content-Disposition: inline --- Outgoing mail is certified Virus Free. Checked by AVG anti-virus system (http://www.grisoft.com). Version: 6.0.720 / Virus Database: 476 - Release Date: 7/14/2004 --=======2B2546CE=======-- --- [Este e-mail foi verificado pelo sistema Anti-v'rus da Netpoint.] sending to informix-list
Fabio Tsuzuki <tsuzuki@spectrum.com.br> writes: > We are trying to configure a Connection Pool with Tomcat 5.0. > We developed an application that runs in Windows environment but when we > migrated to Linux it doesn't work and we got the following message: > > Exception: org.apache.commons.dbcp.SQLNestedException: Cannot create > PoolableConnectionFactory, cause: com.informix.asf.IfxASFException: Attempt > to connect to database server (ol_service) failed. > > We copied all JARs (ifxjdbc) that we used in Windows to Linux, what should > be the reason of this error? > > Thanks a lot > Fabio > What is the version of the jdbc driver? We had a few problems after upgrading Tomcat to a newer version. Are you running the exact same version of Tomcat (or, more specifically commons-dbcp.jar) on the two servers? When we upgraded to the latest jdbc driver the problem were gone. The connection string could also be interesting. Admittably this is a long shot. You don't give much specifics in your post.