IDS 7.3 TC2 Hangs
Posted in 1998
Hi,
I'm having problems with IDS 7.3 TC2 on our NT Box.
I was wondering if this has already been fixed.
The first assertion happens when I insert 2 or more columns in
the middle(using before) of a table either through alter table or dbaccess.
But if I insert 1 column at a time, everything's fine.
Also if append the columns at the end of the table it also works.
(In place alter algorithm bug?)
The second one happens after I drop a stored procedure.
After the exceptions, there server seems to be fine
if you check it with onstat but it won't allow any connections
either through dbaccess or through a client.
I can't even shut it down!!!(onmode -kuy hangs)
Even shutting it down through the Control Panel doesn't work.
My server configuration by the way is quite conservative
using only about 2000 buffers and has less than 10 clients.
(This is a development box)
Thanks
Zandy
15:26:00 Assert Failed: No Exception Handler
15:26:00 Informix Dynamic Server Version 7.30.TC2
15:26:00 Who: Session(219, informix@ARC, 139, 0)
Thread(240, sqlexec, 0, 1)
Exception at Addr: 0x44f6a6, TOS: 0xce43ca8, FP:0xce43ca8, Exc: c0000005
15:26:00 Results: Exception Caught. Type: MT_EX_OS, Context: mem
15:26:00 Action: Please notify Informix Technical Support.
17:24:54 Assert Failed: Memory free block header corruption detected in
mt_shm_malloc_segid 1
17:24:54 Informix Dynamic Server Version 7.30.TC2
17:24:54 Who: Session(64229, informix@it-jtm, 209, 0)
Thread(64727, sqlexec, 0, 1)
File: r:\\belib\\mtshpool.c Line: 2562
17:24:54 Results: Unable to repair pool
17:24:54 Action: Please notify Informix Technical Support.
-----== Posted via Deja News, The Leader in Internet Discussion ==-----
http://www.dejanews.com/ Now offering spam-free web-based newsreading