Everybody RUN - Cobol question
Posted in 2010
Topics: Installation, Setup & Upgrades, Error Codes & Troubleshooting, Connectivity: ESQL/C, 4GL & Embedded SQL, Versions, Editions & End-of-Life
Seriously. Running version 11.5 with ESQL/Cobol version 7.25.UD4X1. I know next to NOTHING about Cobol so forgive my description that follows. I guess we also use Microfocus Cobol that somehow works in conjunction with Informix ESQL/Cobol. Anyway after we upgraded to v11.5 from v10.00.UC8 we had developers call us saying one of their load programs did not work anymore. Apparently something, somewhere has changed with the way the engine/cobol/sunspots handles null and dates and stuff. This is from the developer... BEGIN DEVELOPER SECTION: Using the indicator within the program I get the following error: *--------------------------------------------------------------- * A valid date is specified the program blow with: * * error code: 114, pc=0, call=1, seg=0 * 114 Attempt to access item beyond bounds of memory (Signal 11) * * For the SQL below. *--------------------------------------------------------------- EXEC SQL EXECUTE DBDTNUL_PI USING :CROP-SIGN-DT OF DBDTNUL: WS-CROP-SIGN-DT-IND END-EXEC Running it without the indicator I get the following: *--------------------------------------------------------------- * Date loads correctly if a valid date is specified. * An error of 1205 Invalid month in date will happen when a * blank date is specified. * For the SQL below. *--------------------------------------------------------------- EXEC SQL EXECUTE DBDTNUL_PI USING :CROP-SIGN-DT OF DBDTNUL END-EXEC *--------------------------------------------------------------- END DEVELOPER SECTION I really want to drop back in punt formation on this one - but you know how the database guys know everything right? Yeah. Any help is GREATLY appreciated. The best tip will win a gift certificate for a free Frosty at any Wendy's in the greater Kansas City area... MM
Well I have found a guerrila workaround - maybe gorilla is more appropriate. I copied all of the cobol related files from $INFORMIXDIR/esql/lib over from our version 10 installation into the v11's ../esql/lib directory and the program ran fine. Now I will need to see what file or files(s) is/are the real culprit here. Fire has been put out - no free frosty's. Sorry. MM
For what its worth the problem turned out to be caused by an unknown change to the icobsqls09b.so file in the $INFORMIXDIR/lib/esql directory. When I replaced that file with the same file from the v10 install (and the two associated linked files) our program ran like a champ... Will be curious to see what IBM says about this. Look out support here I come... ;-) MM
MIKE MAGIE wrote: > Seriously. Running version 11.5 with ESQL/Cobol version 7.25.UD4X1. I know > next to NOTHING about Cobol so forgive my description that follows. I guess we > also use Microfocus Cobol that somehow works in conjunction with Informix > ESQL/Cobol. Anyway after we upgraded to v11.5 from v10.00.UC8 we had > developers call us saying one of their load programs did not work anymore. > Apparently something, somewhere has changed with the way the > engine/cobol/sunspots handles null and dates and stuff. This is from the > developer... > > BEGIN DEVELOPER SECTION: > > Using the indicator within the program I get the following error: > > *--------------------------------------------------------------- > > * A valid date is specified the program blow with: > > * > > * error code: 114, pc=0, call=1, seg=0 > > * 114 Attempt to access item beyond bounds of memory (Signal 11) > > * > > * For the SQL below. > > *--------------------------------------------------------------- > > EXEC SQL > > EXECUTE DBDTNUL_PI > > USING :CROP-SIGN-DT OF DBDTNUL: > > WS-CROP-SIGN-DT-IND > > END-EXEC > > Running it without the indicator I get the following: > > *--------------------------------------------------------------- > > * Date loads correctly if a valid date is specified. > > * An error of 1205 Invalid month in date will happen when a > > * blank date is specified. > > * For the SQL below. > > *--------------------------------------------------------------- > > EXEC SQL > > EXECUTE DBDTNUL_PI > > USING :CROP-SIGN-DT OF DBDTNUL > > END-EXEC > > *--------------------------------------------------------------- > END DEVELOPER SECTION > > I really want to drop back in punt formation on this one - but you know how > the database guys know everything right? Yeah. Any help is GREATLY > appreciated. The best tip will win a gift certificate for a free Frosty at any > Wendy's in the greater Kansas City area... I guess it must be something in the 3.50 SDK, I'm sure the tools team will know what's going on ... you have logged a PMR, right? :o) -- Cheers, Obnoxio The Clown http://obotheclown.blogspot.com I will now proceed to pleasure myself with this fish. -- This message has been scanned for viruses and dangerous content by OpenProtect(http://www.openprotect.com), and is believed to be clean.
I was trying to avoid opening a pmr on the issue - especially now that we have a workable solution. But I suppose in the interest of cobol customers worldwide (both of us) I should open one... MM