RE: Query on SQLHOSTS
Posted in 2000
Topics: Server Administration, Networking & sqlhosts Configuration
Thanks for the reply.
My problem was solved. In SQLHOSTS file instead of giving the service name
(sqlexec2) , I gave the port no (1529).
It got connected !!!
But still the mistry remains. I checked the sqlhosts and the /ect/services
thoroughly. the service name is same everywhere. server verison is 730 and
of type OL.
thanks,
Srini
-----Original Message-----
From: Art S. Kagel [mailto:kagel@bloomberg.net]
Sent: Wednesday, May 03, 2000 10:25 PM
To: informix-list@iiug.org
Subject: Re: Query on SQLHOSTS
Add a dash '-' at the end of the isql commandline to go into commandline
mode so you can see the error message if the connection is failing. Then
please post the message, the contents of sqlhosts from BOTH servers and the
relevant entries from /etc/services again from BOTH servers. Also please
post server versions and type for both servers (ie IDS or OL or SE). In
addition also try connecting using dbaccess.
Art S. Kagel
Srinivas Sreekumar wrote:
>
> Hi All,
>
> I have two databases running on two different machines A and B. I have
> logged into machine A and wanted to connect to database@B. In machine A
> sqlhosts file in $INFORMIXDIR/etc dir, I have made an entry for database
> running on server B.
>
> dbservername olsoctcp server-B sqlexec2>
> In machine B , I have made an entry in /etc/services for the service
> sqlexec2:
>
> sqlexec2 1529/tcp sqlexecd
>
> And now when I try to connect from machine A, using isql db@dbservername ,
> isql just opens up (without any errors), but not connected to the
databases.
>
> But the connection is happening for a different dbserver on server A from
> server B.
>
> I am new to Informix, and am badly in need of help.
>
> TIA,Srinivas.
You could also add the service to the /etc/services file on server A. This is
needed to resolve the service name listed in the sqlhosts file to a known port
number.
Srinivas Sreekumar wrote:
> Thanks for the reply.
> My problem was solved. In SQLHOSTS file instead of giving the service name
> (sqlexec2) , I gave the port no (1529).
> It got connected !!!
> But still the mistry remains. I checked the sqlhosts and the /ect/services
> thoroughly. the service name is same everywhere. server verison is 730 and
> of type OL.
>
> thanks,
> Srini
>
> -----Original Message-----
> From: Art S. Kagel [mailto:kagel@bloomberg.net]
> Sent: Wednesday, May 03, 2000 10:25 PM
> To: informix-list@iiug.org
> Subject: Re: Query on SQLHOSTS
>
> Add a dash '-' at the end of the isql commandline to go into commandline
> mode so you can see the error message if the connection is failing. Then
> please post the message, the contents of sqlhosts from BOTH servers and the
> relevant entries from /etc/services again from BOTH servers. Also please
> post server versions and type for both servers (ie IDS or OL or SE). In
> addition also try connecting using dbaccess.
>
> Art S. Kagel
>
> Srinivas Sreekumar wrote:
> >
> > Hi All,
> >
> > I have two databases running on two different machines A and B. I have
> > logged into machine A and wanted to connect to database@B. In machine A
> > sqlhosts file in $INFORMIXDIR/etc dir, I have made an entry for database
> > running on server B.
> >
> > dbservername olsoctcp server-B sqlexec2> >
> > In machine B , I have made an entry in /etc/services for the service
> > sqlexec2:
> >
> > sqlexec2 1529/tcp sqlexecd
> >
> > And now when I try to connect from machine A, using isql db@dbservername ,
> > isql just opens up (without any errors), but not connected to the
> databases.
> >
> > But the connection is happening for a different dbserver on server A from
> > server B.
> >
> > I am new to Informix, and am badly in need of help.
> >
> > TIA,Srinivas.