Re: Cannot commit blob (Error -605)
Posted in 2005
Anthony said:
>
> Hey all,
>
> Walked in this AM and found my system wasn't allowing anyone to insert
> large blobs into the system. Large being > 4K. If someone attempts,
> it throws out the -605 error (using JDBC). Insertions into any other
> table work ok -- including blobs into another table.
>
> I am able to upload smaller blobs, binary representations of small
> files (say, 3KB).
>
> I've done a lookup on the error, and see that it's either a hardware
> error, we've passed the column limits, or we've managed to add new
> blobspace.
>
> The table is "relatively" huge. It's probably 95% or more of our whole
> DB, which is 14GB in size. Which would make this one table more than
> 13.3GB large. MOST, if not all, of that, is stored in a single column
> -- which is a BYTE array. And yes, the blob's are stored inside the
> table space. Probably only about ~68,300 rows.
>
> We're running RH 7.3, and IDS 7.31.UD8.
>
> We haven't added any new spaces recently, and according to onmonitor,
> there's still quite a bit available (another 800MB, give or take) in
> the spaces we have allocated. I'm not ruling out the hardware issue,
> but find it rather unlikely, as the system is otherwise stable, and
> smartd (yes, the primary drives are software RAID-1) shows no errors
> (it does daily checks, and weekly LONG checks).
>
> I've run oncheck -cDI on the table, and other than taking a while, it
> has no problems.
>
> We're waiting on Informix Tech Support to call back [yawn]. I've been
> looking around, but can't find ... WHAT is the limit on the columns?
>
> I'm in the process of making a complete, level 0 backup, and then will
> see about deleting / moving some of the oldest rows in the table to
> another table, and see if that frees up some space. If so, I'll go
> about the process of partitioning up the data. Any chance that this
> will work? Don't think I've seen it, but does this version of IDS have
> any sort of "partioning" support?
>
> Any other possibilities for this problem? Solutions?
How many extents in the table? ALTER FRAGMENT ... INIT IN ... should work.
What happens if you unload, drop, recreate and reload the table (with a
big initial and next extent size)?
--
Bye now,
Obnoxio
"C'est pas parce qu'on n'a rien ` dire qu'il faut fermer sa gueule"
- Coluche
"You are an index and a prologue to the history of lust and foul thoughts."
- William Shakespeare
sending to informix-list