I can't access the database ......./_\\ HELP ~~~
Posted in 1999
Topics: Installation, Setup & Upgrades, Error Codes & Troubleshooting, Connectivity: ESQL/C, 4GL & Embedded SQL, Server Administration, Networking & sqlhosts Configuration, Platform-Specific Issues
Hi, All,
I have ask the problem for a long time. Someone ever answered me,
but the problem still not solved.
Does anybody know how to solve the problem?
And if I don't restart(power off and on) the computer,
how do I shutdown the informix db server and restart it ?
Please help me......
Peary
Hi, All,
I have problems to access the database....
I think this problem happens because i tried to install DBD-Informix
which accessed the demo database but it does not exist on my server.
Before that action, it works well. So I think my environment variable
is all set.(including INFORMIXDIR , INFORMIXSERVER, DBPATH....)
And after that the problem happens!!! I tried to use " ps -aux" to see
which process is run away and kill it, but it didn't work.
Then i reinstalled the Redhat Linux 6.0, Informix SE , ISQL,
ESQL/C,etc. and when i use "isql"(the same as dbaccess) to create(or select)
database, it answers me the error message:
908: Attemp to connect to database server (dbs_rm) failed. ISAM Error: Record is locked.
p.s. "dbs_rm" is my INFORMIXSERVER name.
my /home/informix/etc/sqlhosts : dbs_rm sesoctcp dbserver
dbs_services
I add " dbs_services 8888/tcp" to my /etc/services
I don't know how to release the lock....
Thank you for your help .....
Hi...
>And if I don't restart(power off and on) the computer,
>how do I shutdown the informix db server and restart it ?
"onmode -ky" to shutdown instance and "oninit &" to start it! If in
Windows NT, you can use Command Center or the services in Control Panel.
[]ao
LEO Cardoso
---