Unable to use dbaccess on windows 7
Posted in 2013
Topics: Installation, Setup & Upgrades, Server Administration
Hi,
I have installed Informix CSDK 4.10 (32-bit) at my windows 7 terminal, as per
my understanding, "dbaccess" is part of the Informix CSDK 4.10, but I am
unable to see the "dbaccess" icon under the "IBM Informix Client SDK 4.10"
menu in the windows start menu (all programs).
I can only see the following option under "IBM Informix Client SDK 4.10" menu
1. ConnectTest Demo
2. Documentation Viewer
3. DNS Migrate
4. Find Error
5. Setnet32
6. uninstallclientsdk
Although, I can see the "dbaccess.exe" file is available in the "C:\\\\Program
Files (x86)\\\\IBM Informix Client SDK\\\\bin" directory, but I am unable to run it
from this location as well. When i double-click the "dbaccess.exe" file, a
command prompt window opens and goes away quickly.
I have also set the environment using setnet32 and I can successfully connect
to the remote database server according to the environment using "ConnectTest
Demo" application.
I am getting following message when i have tried executed it directly using
command prompt (please note that I am the local administrator on my windows
machine):
C:\\\\Program Files (x86)\\\\IBM Informix Client SDK\\\\bin>dbaccess.exe
ERROR: Could not initialize the security subsystem. Please ensure that this
account has the necessary privileges and ensure INFORMIXSERVER value exists in
the registry and environment.
So can somebody help me in fixing this issue.
Thanks in advance for your anticipation.
Regards,
Khan
Open the DOS (cmd.exe) command prompt window and try running dbaccess from
there. You should also have your informix-related environment variables set so
that it knows where to find everything, etc.
Whether dbaccess works or not in Windows is a whole separate issue, as I was
unsuccessful in accessing a Developer Edition server instance with dbaccess
after I created the instance with the 12.10FCxDE install wizard.
Have you "ensure that this account has the necessary privileges and ensure
INFORMIXSERVER value exists in
the registry and environment."
??
On 31 July 2013 at 16:02 O KHAN <theultimateboy@hotmail.com> wrote:
> Hi,
>
> I have installed Informix CSDK 4.10 (32-bit) at my windows 7 terminal, as per
> my understanding, "dbaccess" is part of the Informix CSDK 4.10, but I am
> unable to see the "dbaccess" icon under the "IBM Informix Client SDK 4.10"
> menu in the windows start menu (all programs).
>
> I can only see the following option under "IBM Informix Client SDK 4.10" menu
> 1. ConnectTest Demo
> 2. Documentation Viewer
> 3. DNS Migrate
> 4. Find Error
> 5. Setnet32
> 6. uninstallclientsdk
>
> Although, I can see the "dbaccess.exe" file is available in the "C:\\\\Program
> Files (x86)\\\\IBM Informix Client SDK\\\\bin" directory, but I am unable to run it
> from this location as well. When i double-click the "dbaccess.exe" file, a
> command prompt window opens and goes away quickly.
>
> I have also set the environment using setnet32 and I can successfully connect
> to the remote database server according to the environment using "ConnectTest
> Demo" application.
>
> I am getting following message when i have tried executed it directly using
> command prompt (please note that I am the local administrator on my windows
> machine):
>
> C:\\\\Program Files (x86)\\\\IBM Informix Client SDK\\\\bin>dbaccess.exe
> ERROR: Could not initialize the security subsystem. Please ensure that this
> account has the necessary privileges and ensure INFORMIXSERVER value exists
in
> the registry and environment.
>
> So can somebody help me in fixing this issue.
>
> Thanks in advance for your anticipation.
>
> Regards,
> Khan
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>