RE: Problem upgrading from IDS10.00.FC8 to IDS11.50.FC4
Posted in 2009
Ok, Actually found the system table, SYSAGGREGATES ... my question is why doesn't the genxml_d.sql clean them up properly then?
From: informix-list-bounces@iiug.org [mailto:informix-list-bounces@iiug.org] On Behalf Of Plugge, Joe R.
Sent: Wednesday, July 01, 2009 9:17 AM
To: informix-list@iiug.org
Subject: Problem upgrading from IDS10.00.FC8 to IDS11.50.FC4
I am currently running IDS 10.00.FC8 on AIX 5.30 TL10 and I am attempting to upgrade Informix. I have resolved all of the in place alter issues and after installing the engine and bringing 11.50.FC4 up, it converts all of the partition headers just fine and then moves to my first database named CLASS. I get this failure:
10:08:50 processing class
10:08:50 Converting database class ...
10:09:07 Execution of the following statement failed. If you arecurrently in conversion, you may have to restore
from level 0 archive, take corrective action and then
restart conversion.
10:09:07 create AGGREGATE informix.genxmlelem
with (
INIT = init_aggrelem,
ITER = iter_aggrelem,
COMBINE = comb_aggrelem,
FINAL = final_aggrelem,
HANDLESNULLS
);
10:09:07 Conversion failed with SQLCODE = -9400 ISAMCODE = 0
10:09:07 The conversion of the database class has failed.
10:09:07 Conv/rev: Failed to convert component SQL to component version 29
10:09:07 Conversion failed for component SQL : entity_ver 29 != target version 31
10:09:07 Assert Failed: Conv/rev: Failed to convert for component SQL
10:09:07 IBM Informix Dynamic Server Version 11.50.FC4X1
10:09:07 Who: Session(8, informix@ibm171, 0, 7000000206246c0)
Thread(28, convert, 7000000205e6a98, 1)
File: framework.c Line: 673
10:09:07 Results: Dynamic Server must abort
10:09:07 Action: Restart conversion after fixing the problem.
10:09:07 stack trace for pid 176492 written to /wic/scratch/af.4046e03
10:09:07 See Also: /wic/scratch/af.4046e03
10:09:10 framework.c, line 673, thread 28, proc id 176492, Conv/rev: Failed to convert for component SQL.
10:09:14 The Master Daemon Died
10:09:15 PANIC: Attempting to bring system down
The version 10 database had the genxml blade installed into it. Prior to the upgrade I ran the genxml_d.sql script to uninstall it, but apparently, it does not clean up after itself very well. My question is , how would I identify all of the AGGREGATES that I would need to look for to make sure that were deleted prior to starting this upgrade over again?
Joe Plugge