Re: ODBC + IIS4 + INFORMIX = NONO *please read*
Posted in 1998
I can understand that! Why do you even try? Just check out the faq at: Primary site (Beta Version) http://www.smooth1.demon.co.uk Official site http://www.iiug.org/techinfo/faq/faq_top.html (I think you still have to go to the Primary (Beta) site) about ODBC. You will find that you have to read the whitepaper at http://www.openlinksw.com about ODBC. Then download the openlink ver. 3 drivers. Make sure you get the server based version of their drivers. Install the server part on your AIX box's and the generic driver on Windows NT. Your chances of success will have increased substantially. You should however not blame Informix alone. Their native drivers that the Informix CLI product use are not particularly well designed to say the least, but the ODBC drivers are from Intersolv and they are not exactly top notch either. The Openlink drivers are very easy to install, give you very good performance and give extra security options and other features you may find very usefull. They may cost a little more, but they are generally worth it. Nils Myklebust NM Data AS Norway On Mon, 2 Feb 1998 14:08:08 -0000, "Matt Deards" <matt.deards@taywood.co.uk> wrote: >PS. Im fed up with being a beta tester for informix software. After: On Mon, 2 Feb 1998 13:55:41 -0000, "Matt Deards" <matt.deards@taywood.co.uk> wrote: >Hi, > >I writing this post out of sheer frustration and because I would like to >warn any developers before they fall into the same trap as I have. My >company has a large number of Informix databases running on AIX box's with >lots of useful information. One of my tasks as the intranet developer is to >pull in all this information and present it in different ways as HTML. As I >wasn't familiar with Informix I got straight onto the Informix tech support >people & asked them if it was possible to pull out information from the dB's >using ODBC with a plan in mind to write some ASP applications to present >this information. "Yes they said, you need Informix CLI", "OK" I replied >I'll have a couple of copies for the server and my workstation. The CD's >came, I installed one on my workstation and the other on there server >running IIS3 then attempted to test the software to see if it was working. >After several attempts in just getting the demo program to connect I >consulted TechNet & luckily enough it pointed me in the right direction. A >little later on and after some fiddling about on the AIX side of things I >managed to get a connection. I then tested all my existing ODBC connections >from the IIS server and found that they where all dead! The Informix >software had downgraded my ODBC V3 drivers to V2. I then re applied the ASP >part of SP3 for NT and it then upgraded the ODBC drivers back to V3 and >luckily enough kept the V2 Informix drivers. So now, I have IIS3, Informix >V2 ODBC drivers and everything seems to be working, I start developing an >application and when its finished I present to to the viewing public. >Things where fine for a while, but then the -406 memory leak errors started >to appear. Yes I had applied the IIS3 mem leak patch, the -406 was an >INFORMIX error and as time went by & more and more people discovered the >usefulness of my application then sooner it would run out of memory and fall >over completely. Back onto Informix, and eventually they sent me an upgrade >disk which when applied seem to do the trick (to version 7.23.tc2 if your in >the same boat as me). A team decision was then made to do away with frames >on the intranet web sites and to use FP98's shared borders instead, VPN's >where also required so we needed to upgrade the web servers to IIS4. So, I >download the NT4 Option pack, backed up the servers and tried the install, >_BOOM_, no more web server. Right at the very beginning of the installation >I started getting lots of 'Failed to load ociw32.dll' errors then OOP >errors, metabase errors, you name it I probably got it, and believe me I was >as sick as a pig. I basically scrapped to entire installation and started >again. Install NT4, Install IE4.1, Install Option Pack, copy back all web >information to Inetpub, copy back FTP server data, set-up virtual servers, >set-up FrontPage server extensions, set-up rights to secure areas. One last >problem, my boss wants the Informix / ASP application to also work so what >do I do? > >What I did was probably the stupidest thing I could have done, I actually >believed it _might_ be ok now. I run the set-up of the original Informix >CLI disk, run the set-up of the Informix upgrade, and the first thing I was >presented with (after a reboot) was Failed to load ociw32.dll' This, after >another visit to TechNet is the new Oracle ODBC driver, which I can only >assume gets trashed when you install the Informix ODBC driver aswell as the >MS ODBC manager being replaced with an Informix one. Nothing worked, fair >enough I thought, I'll just do as I done before and re-install the ODBC v3 >drivers, Ohhh damn, how do I do this in IIS4? I looked in the IIS4 set-up >program and removed the ADC component which basically removes everything >other than IIS4 including FP98 server extension (which when you have a huge >intranet like us takes 3 to 5 hours to re-install). Once this had >uninstalled I re applied the missing settings and was plagued with even more >errors, 'Wrong ODBC version', 'cant create server object, etc, etc, etc. > >This is as far as I have got so far, I'm waiting for the server to stop >throwing up errors as we speak and then I think i'll trash the lot again and >throw the Informix CLI products to a very low draw in my desk never to be >seen again. > >Anyone else had as many problems as me with this scenario? > >Thanks for persevering with this very long post. >Matt. > > >