Re: help me with Log files matters
Posted in 2003
Hi Friends,
Any know this problem, pls help me to correct it.
It's OK When i inserted big data file into BLOB field in my database from one
apb application via browser at the SAME machine running IDS 9.3 under WinNT,
but this work failed when i did insert as above from other machine
at the same SubNET, when upload transaction uploaded about 30-40 percent of
data file, then it stalled or stopped and issued error mesg "Long transaction
aborted"
but the mysterious thing here is that DB server was seemly trying to process
this aborted transaction, this made CPU is very tired of processing this
transaction
and maybe hang during transaction, consequently all new transactions will be
waiting or can not done.
I took a look closely at column titled USERCPU of VP CPU when i ran onstat -g
glo command
and saw that value of it was up to more 200 or higher, otherwise this value is
around 20 to 30 when i did the same upload via browser at Server machine.
Basically, I set NETTYPE line to soctcp,1,50,CPU in file ONCONFIG (server
machine X86 has one CPU intel 800 MHZ, 500 Mb RAM).
Therefore, pls teach me know why i could not insert big data into BLOB field
via LAN network ?, in while this can do
successfully at the same machine with DB server.
Thanks,
Bernard.
"ART KAGEL, BLOOMBERG/ 65E 55TH" <KAGEL@bloomberg.net> wrote:----- Original
Message -----
From: Kam Bernard
At: 3/18 7:53
>
> Hi,
> I am running IDS 9.3 on WinNT, when i insert or upload big sizing data files
> into Blob field in one database, so data files is big that it needs much log
> spaces (Log files) to help long transaction successfully, i must often add
much
> log files as i insert big data file into database, the problem here is that
> cooked Log files could not be freed by IDS, consequently that next insert
> activity will be stucked by lack of log spaces needed and then transaction
will
> be interrupted when transaction TIME_OUT values expired. To free log files
> physically, i often drop cooked log files and then add new log files for next
> transaction.
ALL logical logs are freed AUTOMATICALLY when they are backed up UNLESS there
is
an active transaction with records in that log, the log contains the current
checkpoint record, or the log is the current log. Indeed the logical log files
you are dropping and readding MUST be free for reuse or onparams would not
permit you to drop them. Whatever problems you are having with your large BLOB
transaction, logical logs not being freed is not it. This is a red herring.
Now, your first problem is that your BLOB field is in table space. You should
move that column into a BLOB space so that it is not logged the same way as
table space BLOB columns are that will reduce the need for so much logical log
space. Second, in the meantime, or if you do not want to move the BLOB to
blobspace, change your load to commit the transaction after every insert or
update that will release the logical log files for reuse immediately after they
are backed up. Third, add more logical log space and try to move all of your
logical logs to RAW file space which is up to 40% faster then COOKED filesystem
space.
Art S. Kagel
> Question: How to free automatically cooked log files (Log files backed up for
> any transaction) ?, i used to use onparams utility to add or drop Log files.
> Thanks,
> Bernard.
>
>
>
>
>
> ---------------------------------
> Do you Yahoo!?
> Yahoo! Platinum - Watch CBS' NCAA March Madness, live on your desktop!
> ATTACHMENT part 2 application/octet-stream name=27085470.htm
---------------------------------
Do you Yahoo!?
Yahoo! Platinum - Watch CBS' NCAA March Madness, live on your desktop!