Re: Network Driver Cannot Open Network Device!!
Posted in 2005
Hi,
I think you are somehow running out of some system
resource. However, I'm not sure it is due to kernel
parameters.
As you are on Solaris, I assume you use TLI (protocol
ontlitcp in sqlhosts file). TLI errno 8 simpy means
"System error" - which is not very much help.
Errno 12 means "Not enough space". So maybe you
are somewhere running out of space - which gets
cleared up by a reboot ?
TIA,
Martin
--
Martin Fuerderer
IBM Informix Development Munich, Germany
Information Management
owner-informix-list@iiug.org wrote on 20.10.2005 17:44:15:
> Hi,
>
> In no particular pattern, i get this error, and the only way out is to
> reboot the server (and take downtime), which is not good. It could
> happen after several monhts, or several days.
>
> 16:56:11 NSF putlocal: t_open error: t_errno = 8, errno = 12.
>
> 16:56:11 listener-thread: err = -25574: oserr = 0: errstr = : Network> driver cannot open the network device.
>
> I've googled qutie a bit for this, and it appears that this is not an
> uncommon error, but wasn't able to find specific solutions.
>
> The 25574 error number merely points to something bad going on in the
> OS/Network area and i am not able to find out what is it.
>
> Informix listens on 2055 and i don't have any other services listening
> on that port, started before or after ifmx startup.
>
> Upon the last reboot i increased the soft and hard file descriptor
> limits. This is a Solaris 7 box, Informix 7.31.UD4. I am pasting the
> /etc/system below, and can also supply the config files if needed -
>
> set enable_sm_wa = 1
> set shmsys:shminfo_shmmax=268435456
> set semsys:seminfo_semmap=64
> set semsys:seminfo_semmni=4096
> set semsys:seminfo_semmns=4096
> set semsys:seminfo_semmnu=4096
> set semsys:seminfo_semume=64
> set semsys:seminfo_semmsl=100
> set shmsys:shminfo_shmmin=100
> set shmsys:shminfo_shmmni=100
> set shmsys:shminfo_shmseg=100
>
> #set hard limit on file descriptors
> set rlim_fd_max = 4096
> #set soft limit on file descriptors
> set rlim_fd_cur = 1024
>
> * vxvm_START (do not remove)
> forceload: drv/vxdmp
> forceload: drv/vxio
> forceload: drv/vxspec
> forceload: drv/sd
> forceload: drv/pci
> forceload: drv/ssd
> rootdev:/pseudo/vxio@0:0
> set vxio:vol_rootdev_is_volume=1
> * vxvm_END (do not remove)
>
> I really hope someone has an answer to this issue, or at least the most
> probable things to check/modify!!!
>
> Thanks,
> Anjan
sending to informix-list