Hi
We are currently using Informix Dynamic Server Version 7.31.UC4 on Unix SysV
R4 MPRAS.
We keep getting frequent Informix freezes on our server caused by the
error numbers 25572,25574, 27001. In this state connections to the application
fail:
listener-thread: err = -25572: oserr = 4: errstr = : Network driver
cannot bind a name to the port.
listener-thread: err = -25574 :oserr = 24 : errstr =: Network driver cannot
open the network device.
listener-thread: err = -27001 :oserr = 0 : errstr =: Read error occurring
during connection attempt
Our NETTYPE is set as tlitcp,3,64,NET
Need your help.
Thanks,
↪ replying to ABDEL ARBAWY
Hi,
most likely you are running out of system resources.
Especially check for the "number of open files", i.e.
how many file descriptors can be in use concurrently.
There may be a system wide limit and a per-process
limit. I'm not sure about MPRAS, but probably these
are kernel parameters.
You can also check the normal limits ( use commands
"ulimit" or "limit", depending on your shell). There's a
hard and a soft limit, where the soft limit can be increased
up to the hard limit by the user himself, and the hard limit
can only be increased by user "root". Normally this should
not be the problem, but I've seen cases where it was, so
you might want to check this as well.
Regards,
Martin
--
Martin Fuerderer
IBM Informix Development Munich, Germany
Data Management Solutions
forum.subscriber@iiug.org wrote on 07.12.2004 16:46:00:
> Hi
>
> We are currently using Informix Dynamic Server Version 7.31.UC4 on Unix
SysV R4 MPRAS.
> We keep getting frequent Informix freezes on our server caused by the
> error numbers 25572,25574, 27001. In this state connections to the
application
> fail:
>
> listener-thread: err = -25572: oserr = 4: errstr = : Network driver
> cannot bind a name to the port.
>
> listener-thread: err = -25574 :oserr = 24 : errstr =: Network driver
cannot
> open the network device.
>
> listener-thread: err = -27001 :oserr = 0 : errstr =: Read error
occurring
> during connection attempt
>
> Our NETTYPE is set as tlitcp,3,64,NET
>
> Need your help.
> Thanks,
>
↪ replying to Martin Fuerderer
Hi,
You are right, i modified the UNIX kernel parameters
(HFNOLIM, SFNOLIM..)
and the problem is resolved.
Best regards,