Fast Recovery locked up
Posted in 2005
Topics: Server Administration, Platform-Specific Issues
Hi people.
Running IDS9.4 FC4 on AIX5.2 10GB memory server used as apps and dbs
server.
After a bounce of the engine last week the instance got stuck in Fast
Recovery. Trying to bring it down didn't work (not onmode -uy nor
onmode -ky). Only the instance is using logging, and logs weren't even10% full. The (jr. informix dba) wasn't willing to find the master
thread and kill it (with kill - 9); for which I can't fault him and no
sr. person was available to do the trick. Now eventually he mnaged to
get hold of a AIX admin, but since he didn't want to kill the
masterthread either there was no other recourse than to reboot the
machine. After which the instance came up without a problem in the
world.
Questions:
) What could cause a fast recovery lockup as this?
) Is it possible during that lockup to find out what causes it?
) Is it possible the reboot to find out what caused it?
We did find a program running against one of the databases in the
instance, but i doubt that would cause the lock. I would expect the
program to fail with an error as 'server not available' or something
like that but it didn't.
Robert
Hi,
you should post 'onstat -m' at least...
Or the relevant lines after 'oninit'.
You should check if there is any activity on your server:
- onstat -u (changes on nreads/nwrites ?)
- onstat -x (changes on curlog/logposit ?)
When there is no activity you should open a Case.
Regards,
try_and_err
r.a.reissaus@risdi.com schrieb:
> Hi people.
> Running IDS9.4 FC4 on AIX5.2 10GB memory server used as apps and dbs
> server.
>
> After a bounce of the engine last week the instance got stuck in Fast
> Recovery. Trying to bring it down didn't work (not onmode -uy nor
> onmode -ky). Only the instance is using logging, and logs weren't even> 10% full. The (jr. informix dba) wasn't willing to find the master
> thread and kill it (with kill - 9); for which I can't fault him and no
> sr. person was available to do the trick. Now eventually he mnaged to
> get hold of a AIX admin, but since he didn't want to kill the
> masterthread either there was no other recourse than to reboot the
> machine. After which the instance came up without a problem in the
> world.
>
> Questions:
> ) What could cause a fast recovery lockup as this?
> ) Is it possible during that lockup to find out what causes it?
> ) Is it possible the reboot to find out what caused it?
>
> We did find a program running against one of the databases in the
> instance, but i doubt that would cause the lock. I would expect the
> program to fail with an error as 'server not available' or something
> like that but it didn't.
>
> Robert
r.a.reissaus@risdi.com wrote:
> Hi people.
> Running IDS9.4 FC4 on AIX5.2 10GB memory server used as apps and dbs
> server.
>
> After a bounce of the engine last week the instance got stuck in Fast
> Recovery. Trying to bring it down didn't work (not onmode -uy nor
> onmode -ky). Only the instance is using logging, and logs weren't even> 10% full. The (jr. informix dba) wasn't willing to find the master
> thread and kill it (with kill - 9); for which I can't fault him and no
> sr. person was available to do the trick. Now eventually he mnaged to
> get hold of a AIX admin, but since he didn't want to kill the
> masterthread either there was no other recourse than to reboot the
> machine. After which the instance came up without a problem in the
> world.
>
> Questions:
> ) What could cause a fast recovery lockup as this?
> ) Is it possible during that lockup to find out what causes it?
> ) Is it possible the reboot to find out what caused it?
>
> We did find a program running against one of the databases in the
> instance, but i doubt that would cause the lock. I would expect the
> program to fail with an error as 'server not available' or something
> like that but it didn't.
>
> Robert
>
Why do you say that the fast recovery has locked up? What was the status
of the engine?
When you say you've found a program running against the instance... How
did you find this? Was the program just running, or do you have any
evidence that it did connect?
And obviously you need to look at the online log file...
Regards.