IDS CRASH WHEN INSTALLING UDR
Posted in 2017
Topics: Installation, Setup & Upgrades, Connectivity: ODBC / JDBC / .NET, Server Administration, Platform-Specific Issues, Java & JDBC Development
Hi IIUG Users, I'm having a big problem when install a java UDR. The system crash each time i execute the "install_jar" routine. My instance specs: - IDS 11.70FC9 - Red Hat 5.6 Message Log extract: 10:07:46 Booting Language <java> from module <$INFORMIXDIR/extend/krakatoa/lmjava.so> 10:07:46 Loading Module <$INFORMIXDIR/extend/krakatoa/lmjava.so> 10:07:46 The C Language Module </opt/informix_prd/extend/krakatoa/lmjava.so> loaded 10:07:46 Loading Module <informix.jvp.dbapplet.impl.JarHandler> 10:07:46 Got the mutex 10:07:46 LD_LIBRARY_PATH=/opt/informix_prd/extend/krakatoa/jre/bin/j9vm 10:07:46 VM args[0]= -Xss512k 10:07:46 VM args[1]= -Djava.security. policy=/opt/informix_prd/tmp/JVM_security 10:07:46 VM args[2]= -Xms16m 10:07:46 VM args[3]= -Xmx16m 10:07:46 VM args[4]= exit 10:07:46 VM args[5]= abort 10:07:46 VM args[6]= -Djava.class. path=/opt/informix_prd/extend/krakatoa/krakatoa.jar: /opt/informix_prd/extend/krakatoa/jdbc.jar:/opt/informix_pr d/extend/krakatoa 10:07:46 Fatal error in ADM VP at mt.c:14093 10:07:46 Unexpected virtual processor termination, pid = 16515, exit = 0xff00 The online.con gives another clue about the error: libjvm.so preloadLibrary(/opt/informix_new/extend/krakatoa/jre/lib/amd64/compressedrefs/li bj9vm26.so): libj9thr26.so: cannot open shared object file: No such file or directory libjvm.so failed to load: j9vm26 I verified the files and they exists. I already opened a ticket to IBM, but they don't seem to found a solution yet. Moreover, i tested on a clean installation with RHEL 5.11 and it worked fine, so the problem seems to be with RHEL 5.6 version. Thanks in advance for your support. Best Regards, Julio Martinez L. DBA
Why's the online.con message stating /opt/informix_new/... while online.log using /opt/informix_prd/... ? I take it that /opt/informix_new/extend/krakatoa/jre/lib/amd64/compressedrefs/libj9thr26.so is present - is the same true with /opt/informix_prd? From: "JULIO MARTINEZ" <jmgandalf@gmail.com> To: ids@iiug.org Date: 11/10/2017 06:47 PM Subject: IDS CRASH WHEN INSTALLING UDR [40184] Sent by: ids-bounces@iiug.org Hi IIUG Users, I'm having a big problem when install a java UDR. The system crash each time i execute the "install_jar" routine. My instance specs: - IDS 11.70FC9 - Red Hat 5.6 Message Log extract: 10:07:46 Booting Language <java> from module <$INFORMIXDIR/extend/krakatoa/lmjava.so> 10:07:46 Loading Module <$INFORMIXDIR/extend/krakatoa/lmjava.so> 10:07:46 The C Language Module </opt/informix_prd/extend/krakatoa/lmjava.so> loaded 10:07:46 Loading Module <informix.jvp.dbapplet.impl.JarHandler> 10:07:46 Got the mutex 10:07:46 LD_LIBRARY_PATH=/opt/informix_prd/extend/krakatoa/jre/bin/j9vm 10:07:46 VM args[0]= -Xss512k 10:07:46 VM args[1]= -Djava.security. policy=/opt/informix_prd/tmp/JVM_security 10:07:46 VM args[2]= -Xms16m 10:07:46 VM args[3]= -Xmx16m 10:07:46 VM args[4]= exit 10:07:46 VM args[5]= abort 10:07:46 VM args[6]= -Djava.class. path=/opt/informix_prd/extend/krakatoa/krakatoa.jar: /opt/informix_prd/extend/krakatoa/jdbc.jar:/opt/informix_pr d/extend/krakatoa 10:07:46 Fatal error in ADM VP at mt.c:14093 10:07:46 Unexpected virtual processor termination, pid = 16515, exit = 0xff00 The online.con gives another clue about the error: libjvm.so preloadLibrary (/opt/informix_new/extend/krakatoa/jre/lib/amd64/compressedrefs/libj9vm26.so): libj9thr26.so: cannot open shared object file: No such file or directory libjvm.so failed to load: j9vm26 I verified the files and they exists. I already opened a ticket to IBM, but they don't seem to found a solution yet. Moreover, i tested on a clean installation with RHEL 5.11 and it worked fine, so the problem seems to be with RHEL 5.6 version. Thanks in advance for your support. Best Regards, Julio Martinez L. DBA ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum.
Hi Andreas, Yes, both files exists on both paths. /opt/informix_prd was the original installation, so after serveral tries i installed on a new fresh path (/opt/informix_ew), it didn't worked either. Sorry for the mess and thanks for your reply. Best Regards, Julio.-