In article <duhonCDCt4q.62z@netcom.com>, duhon@netcom.com (Joey Duhon) writes:
|> I'm running RDS 4GL 4.10 under Online 5.0 on a SCO UNIX 486 box.
|> I've some new code that uses a temp table over and over, and
|> I'm getting -710 errors randomly, but quite often.
...
|> The table is dropped after being used, but is recreated before being
|> used again.
I have some code that does this on a small scale. It used to crash the second
time through; I don't recall the error number, but it didn't make sense, and
seemed to indicate that internal data structures were getting messed up. The
particular manifestation of this that affected me was fixed quite some time
ago, possibly when 4.00 first came out? If I remember correctly, it happened
both under RDS and regular 4GL.
While the bug that I used to see seems to have been fixed, it seems possible that
current versions may still have trouble creating and dropping the same temp table
repeatedly. Do anyone know if there are any open bugs with this effect?
In any case, here's one easy workaround: instead of dropping the temp table and
recreating it, just use "delete" to empty it out. The only problem with this
approach is that it'll be much slower if the temporary table is large.
Good Luck,
--
Harry Bochner
bochner@das.harvard.edu