Backup problem on IDS 92 (Linux)
Posted in 2000
hi All.
Could anybody help me please with the backup procedure.
I use the alarm procedure:
-------------------
BACKUP_CMD="$INFORMIXDIR/bin/onbar -l"
....
case "$EVENT_CLASS" in
20)
#-- Logical Logs are Full - Backup is needed
echo " +%D-%T : trying to backup " >> $ALRM_LOG
echo -e "\\ny\\n" | $INFORMIXDIR/bin/ontape -a >
/dev/null 2>&1
EXIT_STATUS=$?
;;
23)
#-- Logical Log complete
$BACKUP_CMD > /dev/null 2>&1
EXIT_STATUS=$?
;;
-------------------
It works but sometimes not..
I have a lot of problem:
------------------------------
1) Informix shuts down with following messages:
09:30:02 Logical Log 52 - Backup Started
09:30:04 Logical Log 52 - Backup Completed
09:30:04 Logical Log 53 - Backup Started
09:30:06 Assert Failed: Mutex Holder Value is not Null
09:30:06 Informix Dynamic Server 2000 Version 9.20.UC1
09:30:06 Who: Session(3570, cpp@app.les.loc, 22117, 272280636)
Thread(16544, sqlexec, 1037cf58, 1)
File: mt.c Line: 6136
09:30:06 stack trace for pid 537 written to /var/tmp/af.4488ba5d
09:30:06 Process exited with return code 142: /bin/sh /bin/sh -c
/opt/informix/etc/log_full.sh 2 23 "Logical Log 60 Complete." "LogicalLog 60 Complete."
09:30:07 See Also: /var/tmp/af.4488ba5d, shmem.4488ba5d.0
09:30:27 mt.c, line 6136, thread 16544, proc id 537, Mutex Holder Value
is not Null.
09:30:35 The Master Daemon Died
09:30:37 PANIC: Attempting to bring system down
09:30:37 semctl: errno = 22
2) The OnBar utility says:
2000-05-25 11:40:39 28752 28749 /opt/informix/bin/onbar_d -l
2000-05-25 11:40:39 28752 28749 An unexpected error occurred:
/usr/lib/ibsad001.so: cannot open shared object file: No such file or
directory .
2000-05-25 11:40:39 28752 28749 Could not open XBSA library
/usr/lib/ibsad001.so.
2000-05-25 11:40:39 28752 28749 An unexpected error occurred:
/usr/lib/ibsad001.so: cannot open shared object file: No such file or
directory .
2000-05-25 11:40:39 28752 28749 Could not open XBSA library
/usr/lib/ibsad001.so.
2000-05-25 11:40:39 28752 28749 Unable to open file
/opt/informix/etc/sm_versions
No such file or directory
2000-05-25 11:40:39 28752 28749 /opt/informix/bin/onbar_d complete,
returning 142 (0x8e)
---------------------------
Thanks in advance.