Transaction Log Errors in SEv5.03
Posted in 1996
Has anybody had any experience with the following SE errors
-346 Could not update a row in the table.
While processing an UPDATE, the database engine received an
unexpected error. Check the accompanying ISAM error code for
more detailed information on the cause. Possible causes include
hardware errors and locking conflicts.
-121 ISAM error: cannot write log record
The ISAM processor is trying to add a record to the transaction log
and has received an error from the operating system. One probable
cause is that the disk is full. Look for operating system error
messages that may give more information. The transaction log file
can grow quite large. In order to reduce its size you must do two
things. First, make a backup copy of the data file (C-ISAM) or all
database files (SQL). Second, make the transaction log file an empty
file. If these steps are performed routinely, the size of the log file can
be controlled.
We have tried all the above like clearing the log and even bcheck-ing
the table in policy. The table has 28000 +- and we want to update 1
column where col = blah and column = blah . The update should have
modified 17000+- recs but it falls over in dbaccess with the above
messages. The only thing we have not done is drop the log itself.
We have also looked at the disk space and the NPROC & NFILE.
To drop/delete the trans log is it safe to remove the row for tabid=0
from the systables as user informix ?
Any Ideas
Noel
SE v5.03
4GLv4.14
SCO 3.2v4.2