-79704 JDBC connection problem
Posted in 2009
Topics: Installation, Setup & Upgrades, Connectivity: ODBC / JDBC / .NET, Server Administration, Networking & sqlhosts Configuration, Java & JDBC Development
Hi all,
I have a serverA(IDS 11.10 FC3 - db) and serverB(IDS-11.10.UC2 - app) on
different hosts machines.
Both the hosts are trusted and sqlhosts entires correct for each other.
I've set user informix env such that dbaccess on serverB connects to instance
on serverA and can access the databases.
While trying to connect serverA from SQL workbench with following connection
string:
jdbc:informix-sqli://serverB:1700/mydb:informixserver=test
Is this a valid string?
(I'm specifying serverB in the connection sring and not serverA and there are
other tabs for credentials)
Driver - com.informix.jdbc.IfxDriver
JDK 1.4 on local machine wheren SQL workbench is installed.
I get an error
-79704 Can't load driver
IBM Informix JDBC Driver could not create an instance of itself and
register it in the DriverManager class. The rest of the SQLException
text describes what failed.
and the SQL workbench gives me error:
Error:'Can't load driver java.lang.reflect.InvocationTargetException
Pls let me know what should i check in order to get the connection established?
Regards,
Vikas
Hello
I'm able to connect to serverA if I use the connection string as:
jdbc:informix-sqli://serverA:1700/mydb:informixserver=test
Is it necessary for JDBC to have a instance running to establish a connection
with? In that case I'm trying impossible as there is no instance running on
serverB.
apart from creating a small informix instance on serverB what are the other
options that I could explore.
Regards
Vikas
*******************************************************************************
Hi all,
I have a serverA(IDS 11.10 FC3 - db) and serverB(IDS-11.10.UC2 - app) on
different hosts machines.
Both the hosts are trusted and sqlhosts entires correct for each other.
I've set user informix env such that dbaccess on serverB connects to instance
on serverA and can access the databases.
While trying to connect serverA from SQL workbench with following connection
string:
jdbc:informix-sqli://serverB:1700/mydb:informixserver=test
Is this a valid string?
(I'm specifying serverB in the connection sring and not serverA and there are
other tabs for credentials)
Driver - com.informix.jdbc.IfxDriver
JDK 1.4 on local machine wheren SQL workbench is installed.
I get an error
-79704 Can't load driver
IBM Informix JDBC Driver could not create an instance of itself and
register it in the DriverManager class. The rest of the SQLException
text describes what failed.
and the SQL workbench gives me error:
Error:'Can't load driver java.lang.reflect.InvocationTargetException
Pls let me know what should i check in order to get the connection established?
Regards,
Vikas
Not sure what you are trying to do.. If you need to connect to an instance (the instance has to be up), you need to have that hostname and other Informix server details specified in your JDBC URL. VG.