Store Procedure - Report
Posted in 1999
Topics: Error Codes & Troubleshooting
This is a multi-part message in MIME format. ------=_NextPart_000_00B7_01BEF5FA.F615B740 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable Hi I'm using Power Builder 7.0 and Informix, i have a Store Procedure that = returns values for a report, when i execute from my application returns = many rows but suddenly appears this message: SQL Error : -245 Could not position within a file via an index, ISAM = Error -144 Key value locked What can i do? is there something that i have to do or just wait some or = a lot of minutes to execute again? thank u ------=_NextPart_000_00B7_01BEF5FA.F615B740 Content-Type: text/html; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"> <HTML><HEAD> <META content=3D"text/html; charset=3Diso-8859-1" = http-equiv=3DContent-Type> <META content=3D"MSHTML 5.00.2314.1000" name=3DGENERATOR> <STYLE></STYLE> </HEAD> <BODY bgColor=3D#ffffff> <DIV>Hi</DIV> <DIV> </DIV> <DIV>I'm using Power Builder 7.0 and Informix, i have a Store Procedure = that=20 returns values for a report, when i execute from my application returns = many=20 rows but suddenly appears this message:</DIV> <DIV> </DIV> <DIV>SQL Error : -245 Could not position within a file via an index, = ISAM Error=20 -144 Key value locked</DIV> <DIV> </DIV> <DIV>What can i do? is there something that i have to do or just wait = some or a=20 lot of minutes to execute again?</DIV> <DIV> </DIV> <DIV>thank u</DIV></BODY></HTML> ------=_NextPart_000_00B7_01BEF5FA.F615B740--
This is not a multi-part message in MIME format. Hi >I'm using Power Builder 7.0 and Informix, i have a Store Procedure that = >returns values for a report, when i execute from my application returns = >many rows but suddenly appears this message: >SQL Error : -245 Could not position within a file via an index, ISAM = >Error -144 Key value locked >What can i do? is there something that i have to do or just wait some or = >a lot of minutes to execute again? it seems that the key is locked. Maybe it help to set a index on the fields you use in the report query. Tschau Manfred
Related threads
- Conversion to differeent characters sets
- Problem in changing locale via dbexport/dbimport
- RE: openlink error "Unable to load locale categories"