Re: Problems with ODBC: Unable to load locale categories
Posted in 1998
I don't know the true answer, and I do hope someone can help. However I have a creaping suspition that this is realy an Informix problem. We have had similar problems lately, but haven't had time to check into them yet. Every supplier of ODBC drivers will have to use ESQL/C to implement the final part of the driver that actually connect to the database. That may be where the problem comes from. This connectivity software implements part of the NLS or new GLS functionality. If they used new libraries they probably presuppose GLS. If you have a 7.1 version Informix engine there is however no GLS type locale data installed. Therefore it will not work. May be, but I somehow doubt it, you could get it to work by installing the locale data from a newer version of an Informix server. If this truly is the problem the ODBC driver vendor will have to supply different versions of their drivers for different 7.x versions of engines. Now all this could have been avoided if Informix had understood locales just a little bit better. First the default locale (en_us.something) should work without any locale files present at all. Second this locale should have supported 8 bit characters in literal strings. As it does support such characters in variables (in insert/update statements) it's kind of strange to say it mildly that they don't allow them in literal strings. These small fixes whould have alleviated a lot of problems for a lot of customers. May be I am all wrong though. In that case I would love to hear about it. In any case I would love to here more about these issues. On Fri, 08 May 1998 16:00:00 GMT, bob@drutty.demon.co.uk wrote: >Hello all, > >I'm running an informix 7.1 database on a sun ultra 1 (SunOS 5.5.1). I'm >trying to access the tables from a PC using the ISG-Navigator ODBC >connectivity package. The connection is made and the server demon starts the >appropriate agent which then fails with: > >Error -461: Unable to load locale categories. > >This seems to be an informix error rather than one specific to ISG-Navigator >(I get exactly the same problem with OpenLink). Other people have posted >similar problems but the solutions have been specific to CLI(?) connections >(eg. run informix/bin/regcopy.exe on the client - but I don't have any >informix stuff on the client). > >I'm not trying to do anything clever with nls. The database was created (using >isql) with the default 'C' locale by the same username (and environment) as is >being used in the ODBC connection. > >I think I lack basic understanding of what's going on. Can any one explain? >I take it this is about the libraries under /usr/lib/locale/... >What locale is being loaded, the local of the database or the locale of the >session? (though in my case they should be the same). Why can't it load it >from an ODBC agent if it can from an interactive login with the same >environment? Why does the error message seem so smug when you read it for the >umpteenth time? Why don't help desks help? > >please don't be cruel if I've asked a daft question, I am a bear of very >little brain. > > Bob. > >bob@drutty.demon.co.uk > > > >-----== Posted via Deja News, The Leader in Internet Discussion ==----- >http://www.dejanews.com/ Now offering spam-free web-based newsreading Nils Myklebust NM Data AS Norway E-mail: Nils.Myklebust@nmdata.com FAQ at: http://www.iiug.org/techinfo/faq/faq_top.html (Now with ODBC info under "Third party products".)