Re: Urgent. Help me to restore my data
Posted in 2000
I contacted one of my collegues about this. Here is his response:
------------------------------------------------------------------------
Hello,
The error:
"couldn't fork server connection" is probaby because Workgroup Server is still
holding
onto shared memory.
Shutting down the server agent service might help. e.g run: "net stop sagent",
or go
into Control Panel and shut down the server agent service.
If this doesn't work, set the service to manual startup, reboot, and try the
restore.
If that doesn't work, please advise what the tech support case number is and we
can
get it escalated.
------------------------------------------------------------------------
I suspect that the last suggestion (i.e. what is the case number) is possibably
the most important item.
Stathis Alexopoulos wrote:
> Hello, this is my first time in newsgroups, so please forgive me for nay
> mistakes.
>
> I have the following installation
>
> Informix OnLine WS 7.22.TC1
> MS-Windows NT 4.
>
> Recently (27 of December) i upgraded the NT with Service Pack 4, and after
> that every time i tried to start the service "Informix OnLine Message
> Service" i had the message "Error 2140 Internal NT Error".
>
> Fortunatelly i had a backup with "ontape -s -L0" just 30 minutes before the
> crash.
>
> After several discussions ant experiments with my local technical support
> from Informix, they tould me that 7.22 propably does not work Service Pack
> 4.
> So, i reinstalled NT with Service Pack 3 and after that i installed
> Informix, and i had an Informix ready to work.
> I tried then to get my data using "ontape -r". Because it is full restore i
> did it as cold restore, and i had a message from ontape "Cannot fork server
> connection".
>
> Now, my local technical support has no ideas and i have my company not
> working for the three of the most critical days of the year.
>
> If someone has any idea about this problem, please let me know.