HELP REQD. URGENT : Unusual error coming during while trying to change logging status.
Posted in 1999
Topics: Backup & Restore, Installation, Setup & Upgrades, Storage & Space Management, Migration, Import/Export & Data Conversion
Hi All,
I am facing an error when I try to change the logging status. The error
text is
Validating mode transitions to NOLOGGING logging mode...
Database oamdb - Valid, candidate for immediate update.
Posting transitions to NOLOGGING logging mode...
ARC-E-01846, Error received from Informix server while processing
archive or backup.
IFMX-E-API, Error changing logging status - 'oamdb', iserrno 107
ARC-E-01808, Error changing the database logging mode.
I used the following command from onarchive
MODIFY/DBLOGGING=oamdb /MODE=NOLOGGING
I tried changing the logging status with ontape as well as onmonitor
also but evrytime I got a similar error.
In the above text oamdb is one of the databases for which I want to
change the loggin status. I have tried this on three installations on
three different machines but I am getting the same error. Can anyone
throw some light on this ?
I have Informix 6.0 installed & my O.S. is SVR4.
The basic reason why I want to use the above is as I want to use the
onload/onunload utility to load/unload tables from the database . The
reason why I want to do this is as i am having 3 or 4 chunks in my
dbspace. there is a lot of space free in the initial chunks(due to
dropping of some unwanted tables & data) whereas the chunks which i
created later on have a lot of data - a lot of interleaving . My
abjective is to shift the data to the chunks created earlier thereby
getting rid of the interleaving as well as then I will be able to remove
unwanted chunks(which can only be removed if there is no data in it).
Informix experts - please help. Any kind of help will be appreciated. U
can directly reply to my mail id also.
Thanks in advance
Sunil
If you look up what error 107 is, it says that someone has a lock on a
record. You probably have another user on the database. Have you tried
doing this in quiescient mode?
Vic
Sunil Malik wrote:
> Hi All,
>
> I am facing an error when I try to change the logging status. The error
> text is
>
> Validating mode transitions to NOLOGGING logging mode...
> Database oamdb - Valid, candidate for immediate update.
> Posting transitions to NOLOGGING logging mode...
>
> ARC-E-01846, Error received from Informix server while processing
> archive or backup.
> IFMX-E-API, Error changing logging status - 'oamdb', iserrno 107
>
> ARC-E-01808, Error changing the database logging mode.
>
> I used the following command from onarchive
> MODIFY/DBLOGGING=oamdb /MODE=NOLOGGING
>
> I tried changing the logging status with ontape as well as onmonitor
> also but evrytime I got a similar error.
> In the above text oamdb is one of the databases for which I want to
> change the loggin status. I have tried this on three installations on
> three different machines but I am getting the same error. Can anyone
> throw some light on this ?
> I have Informix 6.0 installed & my O.S. is SVR4.
>
> The basic reason why I want to use the above is as I want to use the
> onload/onunload utility to load/unload tables from the database . The
> reason why I want to do this is as i am having 3 or 4 chunks in my
> dbspace. there is a lot of space free in the initial chunks(due to
> dropping of some unwanted tables & data) whereas the chunks which i
> created later on have a lot of data - a lot of interleaving . My
> abjective is to shift the data to the chunks created earlier thereby
> getting rid of the interleaving as well as then I will be able to remove
> unwanted chunks(which can only be removed if there is no data in it).
> Informix experts - please help. Any kind of help will be appreciated. U
> can directly reply to my mail id also.
>
> Thanks in advance
>
> Sunil
i tried doing it in the quiescient mode. It still doesn't work. As soon as i put it in the quiscient mode my oncatglr stops & then even onarchive fails. Putting it in Quiescient mode could help how ?? From the manuals the only information I could get was that IFMX-E-API is an interface error which occurs sometimes when onarchive tries to communicate with online. . It even says that these kind of errors occur when trying to do archives, backups or restores when Online is not in the correct mode. My question is now - What is the correct mode of Online when we have to change the logging status? Can Anybody help me out in giving me a solution to my basic problem(please go thru the initial mail) Thanks in Advance Sunil Vic Goldberg wrote: > If you look up what error 107 is, it says that someone has a lock on a > record. You probably have another user on the database. Have you tried > doing this in quiescient mode? > > Vic > >
In article <37CB1968.40C3443F@americasm01.nt.com>, Sunil Malik
<sunilm@americasm01.nt.com> writes
>i tried doing it in the quiescient mode. It still doesn't work. As soon as i
>put it in the quiscient mode my oncatglr stops & then even onarchive fails.
>Putting it in Quiescient mode could help how ??
>
Do onstat -u and check who is connected. Putting it in Quiescent mode
would disconnect most users from the database. You could then use
ontape to update the logging status.
>From the manuals the only information I could get was that IFMX-E-API is an
>interface error which occurs sometimes when onarchive tries to communicate
>with online. . It even says that these kind of errors occur when trying to do
>archives, backups or restores when Online is not in the correct mode.
>My question is now - What is the correct mode of Online when we have to
>change the logging status?
>
>Can Anybody help me out in giving me a solution to my basic problem(please go
>thru the initial mail)
>
>Thanks in Advance
>Sunil
>
>Vic Goldberg wrote:
>
>> If you look up what error 107 is, it says that someone has a lock on a
>> record. You probably have another user on the database. Have you tried
>> doing this in quiescient mode?
>>
>> Vic
>>
>>
>
--
David Williams