RE: informix and web logic
Posted in 2005
Topics: Performance & Tuning, Connectivity: ODBC / JDBC / .NET, Platform-Specific Issues, Java & JDBC Development
We had a similar problem with weblogic and informix, this is what we did in the weblogic connection pool for informix there is a setting called " Test reserve connection" you also have to provide a table name if this is checked, if you check this setting the connection pool will first query the database and then provide the db connection to the client. what we found was, since the table what we had provided for this option was a tiny table, weblogic query used to do a sequential scan on the table so in case of any lock contention on the table the connection used to fail with -244 informix error. what we had to do to fix this problem was to create a dummy table (like oracle dummy table) and use it in the "Test reserve connection" option. this resolved the issue. we also had similar problem (error -244) with the weblogic heartbeat process, BEA had to provide us a patch for that problem (it appeared that the weblogic did not have set lock mode to wait statement in their code) -----Original Message----- From: owner-informix-list@iiug.org [mailto:owner-informix-list@iiug.org]On Behalf Of tomcaml@yahoo.com Sent: Tuesday, July 19, 2005 4:03 PM To: informix-list@iiug.org Subject: informix and web logic hello we are running infx 9.40 FC3 on HP-UX 11i. Developers use web logic to process batch files (JDBC drivers) - and they use connection pooling. when i create a new DB in dev from Prod data, i start from scratch and then rename DB's, for example DB1 becomes DB1_old and the DB1_new is renamed to DB1, and then developers use the DB1 database. last thing i do is run update stats on each table , proc and view and the whole db. most tables are empty of data what happens is they go to write to tables in the new DB and their application returns an error of -244 "Could not do a physical-order read to fetch next row. " they ask me to re-run update stats and they reset their server connections to the database. has anyone run into this? it does not seem that the update stats really change anything for them but rather the re-setting of their connections....any help is appreciated Thanks Tom sending to informix-list
Thanks so much for the ideas - it is GREATLY appreciated! We will try them and see what comes of it - I once opened a case with support some time ago but they were not able to resolve it. Thanks again, Tom