RE: informix and web logic
Posted in 2005
Is your process finished completely by the time they run their processes ? It could be that a system tables is locked at the time they try to access the database. The other option could be that one of their starting processes is creating a lock, and they are locking each other out. You'll have to try and trace the lock ..... or as the other reply indicated, they could try "set lock mode to wait nn" Dirk -----Original Message----- From: owner-informix-list@iiug.org [mailto:owner-informix-list@iiug.org] On Behalf Of tomcaml@yahoo.com Sent: 19 July 2005 11:03 PM To: informix-list@iiug.org Subject: informix and web logic hello we are running infx 9.40 FC3 on HP-UX 11i. Developers use web logic to process batch files (JDBC drivers) - and they use connection pooling. when i create a new DB in dev from Prod data, i start from scratch and then rename DB's, for example DB1 becomes DB1_old and the DB1_new is renamed to DB1, and then developers use the DB1 database. last thing i do is run update stats on each table , proc and view and the whole db. most tables are empty of data what happens is they go to write to tables in the new DB and their application returns an error of -244 "Could not do a physical-order read to fetch next row. " they ask me to re-run update stats and they reset their server connections to the database. has anyone run into this? it does not seem that the update stats really change anything for them but rather the re-setting of their connections....any help is appreciated Thanks Tom sending to informix-list